vacuum pump/1982 300D Turbo - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 Old 04-15-2004, 10:51 PM
Junior Member
 
Join Date: Feb 2004
Location: San Diego
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
vacuum pump/1982 300D Turbo

My 1982 300D Turbo suddenly lost power assist to the brakes while I was parking. When I turned the key off, the engine kept running. Also, door locks stopped working entirely (they never worked very well).

Well, I checked for obvious leaks in the vacuum lines, and found none. Then, I dismantled the main tube from the vacuum pump and started the engine. When I placed my thumb over the open line, I felt no vacuum from the pump.

Is the vacuum pump the only possible culprit at this point? Or, could there be a bad coupling or gear that drives the pump? If I must replace the pump, or a coupling to it, how difficult is this? Any pointers on doing this job?

Thanks,
15de11
15de11 is offline  
Sponsored Links
Advertisement
 
#2 Old 04-16-2004, 11:09 PM
Veteran Member
 
Join Date: May 2003
Location: Rosamond, CA
Posts: 584
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to cracker928
If you are getting no vacuum from the pump, then a pump service is due. This is a fairly straightforward process that you should not be intimidated by. Alos, be aware that rebuild kits are readily available for your car and if you are mechanically inclined (sounds as though you are) it would be worth doing.

\'87 Mer-B 300D (220,000 miles) (sold)
\'93 Mer-B 300D (173,000 miles) (sold)
\'87 Porsche 928 (101,000 miles)
\'98 Dodge Ram quad-cab (250,000 miles)
\'2001 CLK430 Cabrio (50,000 miles)

Past cars: 1969 mercedes 250, 1981 300D, 1972 220D
cracker928 is offline  
#3 Old 05-14-2004, 07:35 AM
Senior Member
 
Join Date: Feb 2003
Location: Sparta, NC, USA
Posts: 191
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to RivermasterNC Send a message via MSN to RivermasterNC
Re: vacuum pump/1982 300D Turbo

Quote:
Originally Posted by 15de11
My 1982 300D Turbo suddenly lost power assist to the brakes while I was parking. When I turned the key off, the engine kept running. Also, door locks stopped working entirely (they never worked very well)...
Are the door locks operated on the same vacuum system as the brakes, shut-off, etc. on the W123?? I believe the locks on my 1983 W126 are on a separate system, operated by and electric pump. Seems like I do recall my old 240D loosing vacuum actuation of the locks if she sat for a while.

-Scott

Support our Forum Sponsor
http://www.importpartsonline.com
1986 300SDL 190Kmi
1989 560SL 99Kmi
1998 E320S4 127Kmi [FOR SALE]
2000 F250SD 7.3L TurboDiesel 93Kmi
1986 Explorer 195Kmi
1965 VW Beetle 115Kmi
2002 RC New Beetle
=============
Previous MB\'s:
1983 240D Euro 4-Speed Man.
1986 190D 2.5
1991 300D 2.5 Turbo
1983 300SD 495Kmi
RivermasterNC is offline  
#4 Old 05-14-2004, 09:28 AM
Veteran Member
 
Join Date: May 2003
Location: Rosamond, CA
Posts: 584
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to cracker928
Yes, the 123 has all the vacuum accessories on the same system. I believe the 126 chassis was the first to have the separate vacuum pump for the locks.

\'87 Mer-B 300D (220,000 miles) (sold)
\'93 Mer-B 300D (173,000 miles) (sold)
\'87 Porsche 928 (101,000 miles)
\'98 Dodge Ram quad-cab (250,000 miles)
\'2001 CLK430 Cabrio (50,000 miles)

Past cars: 1969 mercedes 250, 1981 300D, 1972 220D
cracker928 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Diesel Discussion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome