1999 c230 kompressor - Page 3 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#21 Old 01-06-2013, 06:16 PM
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Location: Jiangsu province China
Posts: 1,195
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by ReedM View Post
I was hoping you could help with my problem. I have a 1999 C230 Kompressor. This weekend I was changing a flat tire. While the wheel was off the car fell and the dirt shield behind the disk bent. After getting the tire fixed, I tried straightening the shield before putting the tire on. After the tire was on, I started to drive and in a couple of mintues the bas/asr light came on and the car shutoff. After waiting a while, I restarted the car. It idled for a while and then the same thing happened. The bas/asr light came on and the engine shutoff, the car was not moving, it was still in park. Is the problem the asr sensor, if so how do I fix it?
The lights coming on is most probably the wheel speed sensor for the side that was dropped whilst changing the wheel, the sensor is fitted behind the hub. But I do not know why the engine shut off, it should go into limp mode and not completely shut off.

ERIC
eric242340 is offline  
Sponsored Links
Advertisement
 
#22 Old 01-07-2013, 05:45 PM
Junior Member
 
Join Date: Jan 2013
Location: BTR, LA
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
C230 asr

Quote:
Originally Posted by eric242340 View Post
The lights coming on is most probably the wheel speed sensor for the side that was dropped whilst changing the wheel, the sensor is fitted behind the hub. But I do not know why the engine shut off, it should go into limp mode and not completely shut off.
Do you know where I can find a diagram showing where the sensor is and how to replace it? It may be that the sensor was knocked out of postion.

Thanks

Last edited by eric242340; 01-07-2013 at 06:02 PM.
ReedM is offline  
#23 Old 01-07-2013, 06:03 PM
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Location: Jiangsu province China
Posts: 1,195
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by ReedM View Post
Do you know where I can find a diagram showing where the sensor is and how to replace it? It may be that the sensor was knocked out of postion.

Thanks
Left click on the image to enlarge;
Attached Thumbnails
Click image for larger version

Name:	Snap1.jpg
Views:	70
Size:	82.7 KB
ID:	2291  

ERIC
eric242340 is offline  
#24 Old 01-08-2013, 05:17 PM
Junior Member
 
Join Date: Jan 2013
Location: BTR, LA
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by eric242340 View Post
Left click on the image to enlarge;
Thanks
ReedM is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 C230 Kompressor - Defrost and Leg Heater not working lordofthering DIY/Tech Help 1 12-04-2011 05:10 AM
FS: 1999 Mercedes C230 Kompressor W202 deanchoi For Sale, Trade & Wanted 0 08-25-2009 12:57 AM
Oil to be used in 1999 C230 Kompressor cskalyan Mercedes-Benz Sedans/Wagons 3 06-22-2006 10:46 AM
C230 Kompressor SDN or IS 300 Ralidog Mercedes-Benz Sedans/Wagons 2 07-08-2003 07:23 PM
2003 C230 Kompressor vs C180 Kompressor Shanti Mercedes-Benz Sedans/Wagons 11 03-06-2003 08:28 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome