2001 S500 - Strangest Airmatic Problem - Please Help - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 31 Old 05-21-2013, 07:28 PM Thread Starter
Junior Member
 
Join Date: May 2013
Vehicle: 2000 S500
Location: Florida
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Question 2001 S500 - Strangest Airmatic Problem - Please Help

I've read just about all of the Airmatic problems on Google and here but I have yet to find anything on this one.

Most Airmatic issues I have been able to find we're about dropping or not going up, front or rear dropping, pump not running....etc.

My problem has nothing to do with leakage. Quite the opposite. It used to be when I parked the car and walked away the car would drop 2 inches and it would be fine.

Now... I park the car and within a few hours car raises all the way up. I open any door or the trunk lid and the car drops back down to normal. Once I do that, it will stay leveled and not go up on it's own till next time I drive and park it.

Sometimes the whole car would raise, sometimes only the rear.... when the rear raises, the left/rear seems to be higher than the right/rear.

Any help would be greatly appreciated.

Last edited by vagabond90; 05-22-2013 at 07:11 AM.
vagabond90 is offline  
Sponsored Links
Advertisement
 
post #2 of 31 Old 05-22-2013, 03:21 AM
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,728
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
This is a good one, maybe the control unit has gone bonkers LOL. To get started on the diagnostics you will have to have the fault codes read out and then post them here and I will try to help you.

ERIC
eric242340 is offline  
post #3 of 31 Old 05-22-2013, 06:56 AM Thread Starter
Junior Member
 
Join Date: May 2013
Vehicle: 2000 S500
Location: Florida
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by eric242340 View Post
This is a good one, maybe the control unit has gone bonkers LOL. To get started on the diagnostics you will have to have the fault codes read out and then post them here and I will try to help you.
Thanks for responding Eric. Unfortunately, you’re right ! I kind of knew that codes would be the first thing I need. Being a GM Dealership Tech for over 20 years, I should have known better, but I was hoping that someone here has had or heard of that problem. When I was a Tech, I already knew or had an idea what was wrong just by reading the complaint on the R/O, specially if it was a common problem. Kind of like if I would have said that the Right Front drops over night...... the first thing everyone here would say...... check the top of the shock for leaks. lol

Taking it to the dealer I’m afraid that they will charge me more than the car is worth to diagnose it, never the less to repair it. I was trying to take a common sense approach. Perhaps if I knew what all the Airmatic Components are and what they do, I might be able to narrow it down.

Obviously, there are 4 shocks, a valve, a pump, a relay, a reservoir, front and rear level sensors and a module. Am I missing anything ??? We know that if any of the shocks were leaking, it would not cause the car to go up over night, we know that a pump would not make it go up (since it’s not running), the relay controls the pump, so that would not be it.

Would it be possible that if one of the solenoids in the valve block is stuck or not sealing that the air in the canister would be transferred to the shocks and pump them up over night ?? It seems that the rear is jacked all the way up in the morning more so than the front. Is it possible that the rear level sensor has gone bad ?? The reason I’m asking that is because I’ve noticed in the past if I jacked up one wheel the whole car would go up.

I know that when the car is shut off, all the modules go to sleep. When I open a door, everything wakes up. Which is when the car drops and levels to normal height. So, I’m thinking it would either be a bad module or a bad rear level sensor or a valve block. Any of the three that you could eliminate given the symptoms ??
vagabond90 is offline  
 
post #4 of 31 Old 05-22-2013, 09:55 AM
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,728
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Your way of doing diagnostics is to be admired sir, but alas this system is around 10 x more complex than you understand and given the symptoms it leaves me with 50 x the possible causes.

Codes are the real key to narrowing this down. There are plenty of specialist workshops that will simply read the codes for you at a small price. Check the lists out here;

http://www.benzworld.org/forums/reco...-repair-shops/

ERIC
eric242340 is offline  
post #5 of 31 Old 05-23-2013, 07:51 PM Thread Starter
Junior Member
 
Join Date: May 2013
Vehicle: 2000 S500
Location: Florida
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by eric242340 View Post
Your way of doing diagnostics is to be admired sir, but alas this system is around 10 x more complex than you understand and given the symptoms it leaves me with 50 x the possible causes.

Codes are the real key to narrowing this down. There are plenty of specialist workshops that will simply read the codes for you at a small price. Check the lists out here;

http://www.benzworld.org/forums/reco...-repair-shops/
You do have a point Eric. I found a local shop from the list you directed me to. I will take it in next week and I will post their findings..... Thanks again for all your input.
vagabond90 is offline  
post #6 of 31 Old 06-06-2013, 11:09 PM Thread Starter
Junior Member
 
Join Date: May 2013
Vehicle: 2000 S500
Location: Florida
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Hello Eric,

Sorry I took so long to get back. I ended up buying MB Star C3. Great tool !! I love it !!

Anyway, here's what it came up with:

C1121-002 Fault in Component B24/3 (Left front body acceleration sensor).

Replaced it and Voila !! Problem solved !
vagabond90 is offline  
post #7 of 31 Old 05-15-2015, 09:31 AM
Member
 
Join Date: Apr 2015
Vehicle: 1983 300d
Location: San Francisco
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Garage
Hi all
I have some problem with S320 but no one error in air matic
User Name is offline  
post #8 of 31 Old 05-15-2015, 09:39 AM
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,728
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Quote:
Originally Posted by User Name View Post
Hi all
I have some problem with S320 but no one error in air matic
Which diagnostic test equipment did you use to check for fault codes?

ERIC
eric242340 is offline  
post #9 of 31 Old 05-16-2015, 03:08 PM
Member
 
Join Date: Apr 2015
Vehicle: 1983 300d
Location: San Francisco
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Garage
Star diagnose DAS
User Name is offline  
post #10 of 31 Old 05-17-2015, 05:42 AM
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,728
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Quote:
Originally Posted by User Name View Post
Star diagnose DAS
Is it showing any fault codes that you feel are not related to Airmatic?

ERIC
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can u disable airmatic light?? S500 stretch limo changed air shocks to regular Gililimo DIY/Tech Help 3 01-31-2013 04:22 AM
Need help with airmatic/esp/bas/abs light please s500!! Gililimo Mercedes-Benz Sedans/Wagons 0 01-31-2013 04:02 AM
Need help with airmatic/esp/bas/abs light please s500!! Gililimo DIY/Tech Help 0 01-31-2013 04:00 AM
2000 S500 problem need advise mcagroup1 DIY/Tech Help 0 03-14-2008 07:19 PM
1995 s500 heater problem blackwidow Mercedes-Benz Sedans/Wagons 1 03-11-2005 08:34 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome