Right side is lower after control arm change - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-17-2017, 02:07 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Vehicle: 2003 S500 4Matic
Location: Bettendorf, IA
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Right side is lower after control arm change

I recently installed new pads, rotors, ball joints and upper control arms on my 03 S500 4Matic. Now my passenger front side is a little lower than the driver side. The Ride Height sensors are attached correctly. I am pretty sure I don't have any leaks as the car never goes all the way down. The pump sounds like it's working okay and the car goes up when I get in and start it. Is there any way to resync the struts. I do have the Autel DS708 scanner and I can see the airmatic system on it and make changes but I don't know what I am supposed to put in the fields for values.

I saw on some youtube videos people have unscrewed the air hoses from the struts to replace them. Is it possible to support the car and then undo the air hoses at the tops of the struts and then reconnect them and let the compressor fill them up evenly?
mitnworb is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Yesterday, 07:28 AM
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,755
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 67 Post(s)
Check the ride height sensor linkages again, if one gets damaged or bent then this height difference can happen.

ERIC
eric242340 is offline  
post #3 of 3 Old Today, 11:28 AM Thread Starter
Junior Member
 
Join Date: Mar 2017
Vehicle: 2003 S500 4Matic
Location: Bettendorf, IA
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the reply. I did look at the height sensors and they looked like they okay, not bent or anything. After your post I thought to take the wheels off and look at them closer and sure enough the right side sensor didn't have the tab in the locator hole to hold it in place. I reinstalled it and everything is good.
mitnworb is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help--Borrow/rent lower control arm bushing removal/install tool johneb48 DIY/Tech Help 2 12-17-2013 08:57 AM
Need help--Borrow/rent lower control arm bushing removal/install tool johneb48 Mercedes-Benz Sedans/Wagons 0 12-16-2013 11:10 AM
Need help--Borrow/rent lower control arm bushing removal/install tool johneb48 For Sale, Trade & Wanted 0 12-16-2013 11:09 AM
s420 lower control arm karriem DIY/Tech Help 1 03-29-2012 03:49 AM
Broken Front Lower Control Arm? snowisgr8 Mercedes-Benz Sedans/Wagons 1 05-11-2008 12:15 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome