Problems with my 1987 420 SEL - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 Old 08-24-2009, 08:35 PM
Junior Member
 
Join Date: Aug 2009
Location: MA
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to 87SEL
(Thread Starter)
Problems with my 1987 420 SEL

Alright so here are a few problems to list that I know of so far lol.


Car hasn't been driven in about 2 years. Put a new battery in it and started it up and here is what I found.

1. Started up just fine, then after about 2-4 min. idoling the temp went all the way over the red line!

2. Inside the car, the buckle up light keeps flashing when all seat belts are buckled in.

3. There was an annoying siren noise coming out when car was running and idoling.

4. After I let the car cool down (day later) I turned it on once again and a big spark shot out from the grille (dad saw it) then a light cloud of smoke came out through the grille as well.

I started the car again later (just enough to see if it was the battery) so I know its not the battery.


Any help would be fantastic, and any other suggestions as to what else to look for would be awesome as well.

Last edited by 87SEL; 08-24-2009 at 08:48 PM. Reason: incomplete sentence
87SEL is offline  
Sponsored Links
Advertisement
 
#2 Old 08-25-2009, 01:09 PM
Senior Member
 
Join Date: Jul 2008
Location: Old Saybrook, CT
Posts: 148
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
First, check your coolant level. If it is topped up, then make sure the cooling fan is working. There needs to be some reason the car is over heating.

Second, That spark must have been from a short or something. Check to make sure the wiring is all ok.
FCPGroton is offline  
#3 Old 10-10-2009, 11:21 AM
Gan
Junior Member
 
Join Date: Oct 2009
Location: Johor Bahru,Malaysia
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by 87SEL View Post
Alright so here are a few problems to list that I know of so far lol.


Car hasn't been driven in about 2 years. Put a new battery in it and started it up and here is what I found.

1. Started up just fine, then after about 2-4 min. idoling the temp went all the way over the red line!

2. Inside the car, the buckle up light keeps flashing when all seat belts are buckled in.

3. There was an annoying siren noise coming out when car was running and idoling.

4. After I let the car cool down (day later) I turned it on once again and a big spark shot out from the grille (dad saw it) then a light cloud of smoke came out through the grille as well.

I started the car again later (just enough to see if it was the battery) so I know its not the battery.


Any help would be fantastic, and any other suggestions as to what else to look for would be awesome as well.

Wah .. 2 years PARK ... really rest Ooohs ...

Do You Check The Radiator water Level ... before start the engine ..??
it may dry out .. due to leak .. temp. shoot up RED point

the spark Shot from the Grill ... ??
something wrong with the wiring ...
better get an Expert / Technician to attend @ check on it ..
it may cause BURNT ... then the game is OVER .. !!

The Safety Belt Buckle light blinking ...
probably due to poor contact ..
try to spray or clean it with contact cleaner ...

Annoying sound heard when idling ...??
check belting , All moving part bearings .. alternator , water pump ... etc

the Battery just supply the current for starter motor
it can be More then a battery faults BECAUSE the car had PARKED for so long ...

Advice you to get a mechanic to attend it or TOW it to Workshop ... Cheers

Last edited by Gan; 10-11-2009 at 01:45 AM.
Gan is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > General Mercedes-Benz


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
420 sel anyone mrcustom23 Off Topic/New Member Introductions 0 08-10-2007 02:41 AM
For Sale in Ontario, Canada -- 1987 420 SEL teepee For Sale, Trade & Wanted 0 07-13-2005 02:14 PM
For Sale in Ontario, Canada -- 1987 420 SEL teepee For Sale, Trade & Wanted 0 07-13-2005 02:06 PM
1989 420 SEL Heater/Cooling Problems - no heat PaJack Mercedes-Benz Sedans/Wagons 2 02-28-2005 07:50 PM
Info on 1987 420 SEL linapoepoe Mercedes-Benz Sedans/Wagons 1 06-01-2004 06:29 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome