GL450 Won't start sometimes - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 Old 01-18-2013, 07:34 AM
Junior Member
 
Join Date: Jan 2013
Location: Nashville Tn
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
GL450 Won't start sometimes

I have a 2007 GL450 with 58000 miles that won't start some of of the time. Starts fine in the morning. After using the car it will start after sitting for a short time (20 min or less) or a long time 2+ hours but not in between? It will turn over just fine. The battery is strong and the starter works fine. It seems like its not getting gas. It'll try to come to life and rumble on for a couple of seconds then dies. I can try this 20 times to no avail. Any thoughts on what may be causing this?
POLONASH is offline  
Sponsored Links
Advertisement
 
#2 Old 01-21-2013, 12:38 PM
Junior Member
 
Join Date: Jan 2013
Location: Nashville Tn
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I just wanted to add that I don't have a check engine light warning.
POLONASH is offline  
#3 Old 01-24-2013, 12:47 AM
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Location: Jiangsu province China
Posts: 1,196
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Possible crankshaft position sensor, when this gets warm it tends to fail but works ok when cool. If it does not send a signal then the fuel pump will not turn on.

ERIC
eric242340 is offline  
#4 Old 01-29-2013, 03:36 PM
Junior Member
 
Join Date: Jan 2013
Location: Nashville Tn
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
It's at the shop now and it's not the crank sensor. They're looking further into it. The mechanic says its losing fuel pressure when it's hot. He's ruled out any injector issues. Probably unrelated but one of the codes it gives is for EVAP emissions leak detected but he doesn't think that has anything to do with it. Maybe just a gas cap not being tightened enough at some point.
POLONASH is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > M/G/GL/GLK Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
E.I.S. (Electronic Ignition System) problems/failure - new vehicle...(2011/GL450) insidetheknow General Mercedes-Benz 0 07-26-2012 12:20 PM
2008 GL450 Shop Manual dbauer General Mercedes-Benz 0 09-01-2010 04:39 PM
Land Rover LR4 vs Lexus GX 460 vs Mercedes GL450 trev0006 M/G/GL/GLK Class 0 05-18-2010 10:04 AM
OFFSET/BOLT PATTERN GL450 Love my GL General Mercedes-Benz 1 06-02-2006 09:33 PM
Introducing the official 1st GL450 with Bling! Love my GL M/G/GL/GLK Class 0 06-02-2006 02:07 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome