1994 E320 Car Died, will not start - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 Old 02-23-2010, 08:56 AM
Junior Member
 
Join Date: Nov 2008
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Exclamation 1994 E320 Car Died, will not start

Ok, my wife was driving today, car died, will not start. It turns over fine, but shows no sign of cranking. Fuel pump??

1994 E320 Wagon, 160,000 miles.

I've tried to get my wife out of this car, but she loves it. LOVES it. Problem is at this age, parts are going, and this is just the first major issue.

HELP please. I need to get home now, tow the car, & diagnose.
keithp777 is offline  
Sponsored Links
Advertisement
 
#2 Old 02-23-2010, 09:43 AM
Administrator
 
RedLiner's Avatar
 
Join Date: Jun 2009
Location: Spain
Posts: 655
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
It could be so many things, no spark, no fuel, no air etc.

If the car just died it could be the fuel pump relay (engine bay I think) or the crankshaft position sensor. Also check the fuel pump connections and that they are running properly (under the rear passenger seat I think). It could also be the fuel filter clogged if it's not been changed for a while.
Most MBs of that year also had wiring harnesses that disintegrate, if yours wasn't changed it could also be the problem.
Anyway check the simple things first.

I'm not too familiar with your model so I may be wrong as to where the FP relay and pump/s are.
RedLiner is offline  
#3 Old 02-23-2010, 11:17 AM
Junior Member
 
Join Date: Nov 2008
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
no spark. pulled a plug wire, no spark. getting good spark, car ran for a second, then died. cranked a second time, ran for a second, then died. will not crank third time. let it sit for 30 minutes, same deal. craks for a second twice, then nothing.
keithp777 is offline  
#4 Old 02-23-2010, 12:45 PM
Administrator
 
RedLiner's Avatar
 
Join Date: Jun 2009
Location: Spain
Posts: 655
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by keithp777 View Post
no spark. pulled a plug wire, no spark. getting good spark,
Do you mean the spark is intermittent?
RedLiner is offline  
#5 Old 02-23-2010, 02:19 PM
Junior Member
 
Join Date: Nov 2008
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Sorry- I was working on the car last post- mad & in a hurry.
The car will occasionally start, run for about 5 seconds, & shut down. I pulled aplug wire, & when it shuts down, the spark goes, not the fuel. So, Crank sensor, Cam sensor, or both?

Any ideas? Need help. Mechanic by trade, Mercedes owner by marriage.
keithp777 is offline  
#6 Old 02-23-2010, 03:27 PM
Administrator
 
RedLiner's Avatar
 
Join Date: Jun 2009
Location: Spain
Posts: 655
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Keith, although the model in this link is not your model, the info on diagnostics is very relevant http://www.k6jrf.com/MB_X11.html

Pre 1996 models use the OBD1 diagnostic system, if you follow the advice on how to read and clear codes, you should be able to determine where your problem lies.
My 1993 SL500 has the same system and I constructed a simple LED code reader. If your car has the LED in the engine bay as shown in the above link, that will be easier to use.

The attached PDF will show your model and the the DTC fault codes.
Attached Files
File Type: pdf Diagnostic Codes.pdf (876.0 KB, 170 views)
RedLiner is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Mercedes-Benz Sedans/Wagons


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help!! 260 E ABS came on car died. skydog DIY/Tech Help 3 02-01-2008 07:06 PM
AC Evaparator on 1994 E320 Cab. farmtunes DIY/Tech Help 1 07-18-2006 11:35 AM
1994 E320 coupe sport? hvdb Mercedes-Benz Sedans/Wagons 5 12-21-2004 01:41 PM
1994 E320 Wagon Questions connerlai Mercedes-Benz Sedans/Wagons 1 02-19-2004 11:09 AM
1994 e320, good car? rlagm3 Mercedes-Benz Sedans/Wagons 2 11-09-2003 12:33 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome