problems starting a C280 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 06-14-2003, 01:24 PM Thread Starter
Junior Member
 
Join Date: Jun 2003
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to tvgm84
(Thread Starter)
problems starting a C280

Hi, this is my first post.

Anyways, I have a 1998 C280 and randomly the car will not start. It will take sometimes 2, sometimes as many as 10 turns of the key before it will. I have taken it in to a shop, and they have been unable to find the problem. I was hoping someone else has had this problem and knows how to fix it. Thanks.

-Eric
tvgm84 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 09-23-2003, 02:46 PM
Junior Member
 
Join Date: Sep 2003
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
starting problems in C280

i get this frequently, and suspect it is a vapor lock.

Did you ever resolve your problem?
graham whitehouse is offline  
post #3 of 11 Old 02-22-2004, 08:56 AM
Junior Member
 
Join Date: Feb 2004
Location: ajo, az
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to vivaslavs
Problems starting

It may not be mechanical, have you checked to see if you key fob is loose in the ignition? Some models have had problems with a loose key fob, in turn causing them not to start. You may want to check that as well.
vivaslavs is offline  
 
post #4 of 11 Old 02-23-2004, 06:56 AM
Veteran Member
 
Join Date: Dec 2003
Location: Terrapin Station
Posts: 1,472
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
the first thing you should check is your fuel pressure. you can hook a gauge up right to the fuel rail and observe what it does when you attempt to crank the engine. if it does not rise to 4 bar, you need to chek the fuel system (pump, pump relay, etc.).
if fuel is ok, check the air filter and the plugs. it is best to make sure the simple stuff is working correctly before racking your brain on more complex diagnosis. it is possible you have a coil that is not working. in most of these cases, you would have a check engine light as it is misfiring and could damage the TWC.
PHAEDRUS242 is offline  
post #5 of 11 Old 04-14-2004, 07:59 PM
Junior Member
 
Join Date: Apr 2004
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: problems starting a C280

Quote:
Originally Posted by tvgm84
Hi, this is my first post.

Anyways, I have a 1998 C280 and randomly the car will not start. It will take sometimes 2, sometimes as many as 10 turns of the key before it will. I have taken it in to a shop, and they have been unable to find the problem. I was hoping someone else has had this problem and knows how to fix it. Thanks.

-Eric
I have a 1994 C280 and have had the same problem since I bought it. It can happen once server months or server times in a month. The shop could not figure out the problem. I finally find way to work around the problem. When this problem occurs, just pull the ignition key out and wait for at least one minute. Insert the key and the engine start in just one turn. It works for me 99% of times. Only once recently, I have to left car for 2 hour before I can start it. Some one told me that when fail to start the engine, pulling out the key will cause the embedded computer to reset itself.

I would like to see if anyone has fixed the problem or better solution.

Jian
jian is offline  
post #6 of 11 Old 04-15-2004, 06:49 AM
Veteran Member
 
Join Date: Dec 2003
Location: Terrapin Station
Posts: 1,472
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
one, taking the key out will not reset anything. two, where are you taking the car? if you're at an independent, i suggest taking it to a dealer where they understand the way these systems work together and how to fix the problem. if you are going to a dealer and they don't seem to be able to fix the problem, is it because they can't verify its existence or that their previous attempts have failed? there are not issues on these vehicle that cannot be fixed. yes, MB's can be quirky, but should never leave you stranded or not start. regardless, the shop you go to is not doing their job properly, and this situation needs to be addressed. i have never expected one of my clients to just accept and inconvenient malfunction on their vehicle and i can't understand why any other facility that works on MB would either.
PHAEDRUS242 is offline  
post #7 of 11 Old 04-15-2004, 08:26 PM
Junior Member
 
Join Date: Oct 2003
Location: Oakville
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
On a 94, I would say the OVP. I'm not sure the 98 still have the OVP.
It's a metal box withh a fuse on top. Located in the engine bay, passenger side, towards the back under the plastic cover.
cil254 is offline  
post #8 of 11 Old 08-20-2004, 06:00 PM
Junior Member
 
Join Date: Aug 2004
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
took out my neg on the batt and on again... then it starts.
eyeswater is offline  
post #9 of 11 Old 01-05-2005, 07:16 PM
Junior Member
 
Join Date: Dec 2004
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Guys,
I have a 95 C280 and I am having the exact problem! I could only start after 5 - 10 mins.

Please clarify with me when your cars couldn;t start, it could crank right? and the rear view mirror interior lights start flashing alternately?

I do believe it is not a mechanical problem too.

Please help!
thegirlilove is offline  
post #10 of 11 Old 01-21-2005, 08:39 AM
Junior Member
 
Join Date: Jan 2005
Location: Dallas
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
C280 Starting problems

I have a '98 C280 Sport and was having the same problem. After changing the fuel filter (integrated pressure regulator), I took it to the dealer and the best guess that they came up with was the Crank position sensor. They changed it and shazaam, works like a champ.
Nealbob is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Mercedes-Benz Sedans/Wagons


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome