System Restraint !!! SRS - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 01-13-2004, 07:04 PM Thread Starter
Junior Member
 
Join Date: Jun 2003
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
System Restraint !!! SRS

This is the message that I am getting when I start my car. It says:
"SYSTEM RESTRAINT! SRS
VISIT WORKSHOP"

I guess this means AIRBAG FAILURE!!! WOW

I'm driving a 2002 C320 and have done only 16000 miles on it.
I would just like to know what others think of this... as far as I am concerned, this is quite an emergency!!!
I called my dealer and they don't have an appointment for a month. The lady taking appointments tells me that "If I were you, I wouldn't worry about it" "you can bring it in and the service people can take a look at it and if needed, you can leave the car ... and I don't know how long it would take... but I sure don't have a loaner car for you!!!" Is this what Mercedes Benz thinks of a 2002 C320 with Airbag failure???

The C320 is really nice to drive and it's a Great car as long as nothing goes wrong... which quite often does and then comes the sucky part... trying to get your car fixed under warranty...

If anyone can also tell me how to contact Mercedes Benz Corporate, that would be nice.

Thanks
dmad is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-13-2004, 09:30 PM
Veteran Member
 
Join Date: May 2002
Location: Saint Louis, MO
Posts: 1,950
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
This could be as simple as a loose wire. However, when you see that message that means the airbags won't work. "Don't worry about," is not an adequate answer. This is a serious saftey issue. Tell them the advanced airbag system is one of the reasons you bought a Mercedes. Talk to a Service advisor and if you don't get satisfaction from the SA, go to the Service Manager, then to the General Manager. Be respectful, but very, very firm.

2002 C230k, 6 speed, Jaspisblau, Charcoal Leather, C4, C5, C7, Euro COMAND


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Lynn is offline  
post #3 of 5 Old 01-13-2004, 09:57 PM Thread Starter
Junior Member
 
Join Date: Jun 2003
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks Lynn...
I'm taking the car tomorrow morning w/o an appointment... hope things work out... will post my experience.
dmad is offline  
 
post #4 of 5 Old 01-14-2004, 05:57 PM Thread Starter
Junior Member
 
Join Date: Jun 2003
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
took the car in today, early in the morning.
Told them about the SRS warning light and said that I don't have an appointment. They didn't say anything and took the car in.
The only thing was that there was no loaner car (although I knew that U can't get a loaner w/o a month's wait) and they did not know how long it would take... they said that they'll call us when it's done!
That's all the conversation we had.

Got a call in the afternoon that my car was fixed and I could pick it up. There was a problem with the computer codes... like Lynn said (might be loose wire) and they fixed it.

so, basically, the experience this time wasn't too bad...

dmad
dmad is offline  
post #5 of 5 Old 01-15-2004, 04:30 PM
Junior Member
 
Join Date: May 2003
Location: Orlando
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
That same exact thing happened to me when I took my car in for service A. But what sucks is that when they returned the car to me, right when I pulled in my driveway the SRS light right back on. They were able to give me a loaner vehicle immediately which was cool but the problem wasnt. I already had the loaner car for two days because they were behind. They claim that the problem was that there was a cable malfunction. I asked them if they fixed the problem, why did it happen again. They just said, "We always have that problem for some reason." Thats it, but like I told him, if that happens after the warranty expires, they better fix it for free... I ended up having the loaner car for over a week. RIDICULOUS
escaleraa is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Mercedes-Benz Sedans/Wagons


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome