Radio Stopped Working - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 Old 06-04-2004, 07:34 PM
RES
Member
 
Join Date: Sep 2003
Location: Trumbull, CT.
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Radio Stopped Working

I had a small dent removed just behind the rear door on the wheel arch on my 2004 C230. When I got the car back, the radio stopped working. Everything lights up and everything mechanical works but no sound. It also doesn't recognize the CD changer. No sound from radio, CD changer or tape player. Any clues what could be wrong?
RES is offline  
Sponsored Links
Advertisement
 
#2 Old 06-05-2004, 06:00 AM
Junior Member
 
Join Date: May 2004
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Does the sound return if the dent is replaced?

It may be the the MOST fiber optical cable was damaged. If so, an error code would show up when the vehicle is interrogated.

analyst
wingless is offline  
#3 Old 06-05-2004, 01:38 PM
RES
Member
 
Join Date: Sep 2003
Location: Trumbull, CT.
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks Wingless. It would be an expense experiment to try, since that tiny little dent cost me a $1100 to fix. What is the route of this optical cable? Is it any where near the rear fender?
RES is offline  
#4 Old 06-05-2004, 06:09 PM
Veteran Member
 
Join Date: May 2002
Location: Saint Louis, MO
Posts: 1,950
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
There are many electronic cables in that area, but it could be a damaged fiber optic cable from the headunit to the Bose amp. That would explain why there is no sound and why the cd changer is not found.

2002 C230k, 6 speed, Jaspisblau, Charcoal Leather, C4, C5, C7, Euro COMAND
Lynn is offline  
#5 Old 06-05-2004, 09:52 PM
RES
Member
 
Join Date: Sep 2003
Location: Trumbull, CT.
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks Lynn:
Is it possible that the radio needs a security code to be re-activated, assuming the battery was disconnected.
RES is offline  
#6 Old 06-05-2004, 11:21 PM
Veteran Member
 
Join Date: May 2002
Location: Saint Louis, MO
Posts: 1,950
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
MB stopped using radio codes a few years ago. Back when the radios needed a code, the radio would display "CODE".

2002 C230k, 6 speed, Jaspisblau, Charcoal Leather, C4, C5, C7, Euro COMAND
Lynn is offline  
#7 Old 06-06-2004, 06:20 AM
RES
Member
 
Join Date: Sep 2003
Location: Trumbull, CT.
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks Guys for all your help. I will have to contact the body shop on Monday with this information. It sounds like a messy situation to resolve. I will let you know how I make out.
RES is offline  
#8 Old 06-07-2004, 10:37 AM
RES
Member
 
Join Date: Sep 2003
Location: Trumbull, CT.
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
This morning when I went to use the car, the radio was working again like nothing had happened. Very strange.
RES is offline  
#9 Old 06-10-2004, 09:47 AM
Member
 
Join Date: Jun 2003
Location: Montreal, Canada
Posts: 94
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My radio is a real lemon.
When the temperature riches 80F it stops working for a few seconds and works again for a couple of minutes and so on. At MB they are not able to diagnose the problem....
andkovacs is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Mercedes-Benz Sedans/Wagons


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome