Hybrid S400 cannot start - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 28 Old 04-10-2014, 10:16 AM Thread Starter
Member
 
tuysombo's Avatar
 
Join Date: Apr 2014
Vehicle: S400
Location: Phnom Penh
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Post Hybrid S400 cannot start

Dear all,

Please give some idea, I have S400 Hybrid after motobike hit the door and all the side airbag exploded. I have installed all new airbag and module but the airbag light illuminated.

My concern that the car cannot start the engine at all, I have parked this car over 3 months and I concern if the hybrid battery will be damaged also.

1- How can we start the engine again after the crash? Any reset button ?
2- Can we charge the hybrid battery if the car cannot start? Through battery charger or something?
3- Can it be SRS light preventing from vehicle starting?

I have checked with the local garage but seem he cannot make it work again. SRS light still on because the SRS module is not yet code.

Expect to get some input....

Best regards,
SOmbo
tuysombo is offline  
Sponsored Links
Advertisement
 
post #2 of 28 Old 04-11-2014, 03:11 AM
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,762
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 68 Post(s)
I am sure the SRS is not causing this problem but to take a deeper look at the system I will need your vin number, then I can use WIS to find a way of doing this.

ERIC
eric242340 is offline  
post #3 of 28 Old 04-11-2014, 04:57 AM Thread Starter
Member
 
tuysombo's Avatar
 
Join Date: Apr 2014
Vehicle: S400
Location: Phnom Penh
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
WDDNG9FB8BA400230.

I still have K88 fault in SRS as Pyrotechnical separator is too high. Not sure what it's.

1- is there a way to reset to get the engine start again after accident ?


Sent from AutoGuide.com Free App
tuysombo is offline  
 
post #4 of 28 Old 04-11-2014, 05:00 AM Thread Starter
Member
 
tuysombo's Avatar
 
Join Date: Apr 2014
Vehicle: S400
Location: Phnom Penh
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
tuysombo is offline  
post #5 of 28 Old 04-11-2014, 05:18 AM
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,762
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 68 Post(s)
Quote:
Originally Posted by tuysombo View Post
I see from this pic you are using Star diagnostics, do you still have access to it? The fault code shown in the pic is in blue, if you press F3 on the computer panel with this code showing it will take you to the next stage of diagnostics and tell you what to check next.

ERIC
eric242340 is offline  
post #6 of 28 Old 04-11-2014, 05:38 AM
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,762
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 68 Post(s)
According to EPC you have two batteries, a high powered battery in the engine compartment for the Hybrid system and a starter battery in the trunk.

You will need to take all the pannelling out of the trunk to find it. Do not jump start the engine and it is better to disconnect the starter battery and charge it first then reconnect to the car.

ERIC

Last edited by eric242340; 04-11-2014 at 05:41 AM.
eric242340 is offline  
post #7 of 28 Old 04-11-2014, 05:51 AM Thread Starter
Member
 
tuysombo's Avatar
 
Join Date: Apr 2014
Vehicle: S400
Location: Phnom Penh
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I have connected my CTEK battery charger everyday to make sure the starting battery is fully charged and survive.

You mean you think the starting battery low? Or you want to do a hard reset?


Sent from AutoGuide.com Free App
tuysombo is offline  
post #8 of 28 Old 04-11-2014, 05:58 AM
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,762
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 68 Post(s)
Quote:
Originally Posted by tuysombo View Post
I have connected my CTEK battery charger everyday to make sure the starting battery is fully charged and survive.

You mean you think the starting battery low? Or you want to do a hard reset?


Sent from AutoGuide.com Free App
I thought the battery may be low but this is obviously not the case so you should concentrate on the SRS problem. Do you have star diagnostics?

ERIC
eric242340 is offline  
post #9 of 28 Old 04-11-2014, 06:01 AM Thread Starter
Member
 
tuysombo's Avatar
 
Join Date: Apr 2014
Vehicle: S400
Location: Phnom Penh
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Yes. I do have star. But to get it program the SRS module is very poor.

I have team viewer if you could help.


Sent from AutoGuide.com Free App
tuysombo is offline  
post #10 of 28 Old 04-11-2014, 06:10 AM
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,762
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 68 Post(s)
I have team viewer 8 but cannot use it as it is in Chinese. Is the SRS moduld new or used?

ERIC
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Mercedes-Benz Sedans/Wagons > S class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mercedes E300 BlueTec Diesel Hybrid, E400 Hybrid to Bow at Detroit Auto Show AutoGuide.com Site News 0 12-30-2011 11:23 AM
Mercedes S400 Hybrid trev0006 Mercedes-Benz Sedans/Wagons 0 03-24-2010 12:14 AM
MotorWeek - 2010 Mercedes S400 Hybrid trev0006 General Mercedes-Benz 1 03-12-2010 09:02 AM
2010 Mercedes-Benz S400 Hybrid Review Administrator Site News 1 02-19-2010 06:06 AM
2010 Mercedes-Benz S400 BlueHybrid trev0006 General Mercedes-Benz 1 08-25-2009 01:11 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome