Help! I have a RED instrument display - Mercedes-Benz Forum
Mercedes-Benz Forum Mercedes-Benz Forum Header Right

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Mercedes-Benz Sedans/Wagons

BenzForum.com is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 01-19-2013, 12:28 PM   #1
mercforEd
Junior Member
 
Join Date: Dec 2012
Vehicle: 2003 C240
Location: Pompano beach
Posts: 3
Exclamation Help! I have a RED instrument display

My C-240 dash display tells me I need to return to the workshop because of the Battery/alternator. I have load tested both in my garage and they show fine. How do I reset this malfunction and will it resolve the issue?
mercforEd is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-24-2013, 12:15 AM   #2
eric242340
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: S320 W220/Zotye 1.3
Location: Jiangsu province China
Posts: 1,168
What is the voltage reading with the engine off and again with engine running?
__________________
ERIC
eric242340 is offline   Reply With Quote
Old 01-25-2013, 01:52 PM   #3
Ajumani
Junior Member
 
Join Date: Jan 2013
Vehicle: E430 1999
Location: Ottawa
Posts: 1
Help! I have a RED instrument display

Hey I just got the same Problem. Red light in my dashboard. I know found out the I have to replace my Alternator belt. Here in Canada it only cost me $22. Trying to fix it tomorrow. I found a diagram online how to change it. Good luck to you. Hope you find the problem.
Ajumani


Sent from AutoGuide.com Free App
Ajumani is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Mercedes-Benz Sedans/Wagons


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dashboard display issue poppagiorgio Mercedes-Benz Sedans/Wagons 3 03-26-2008 01:10 PM
LED Display RisCa05 Mercedes-Benz Sedans/Wagons 2 05-30-2006 02:28 PM
Display - 1999 E300 ncofmbd Mercedes-Benz Sedans/Wagons 2 11-16-2005 03:32 PM
BAS / ESP ON THE DISPLAY ( VISIT WORKSHOP) KRK DIY/Tech Help 1 06-24-2005 12:16 PM
Information display jacobi Mercedes-Benz Sedans/Wagons 1 02-27-2005 10:53 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 05:39 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide