Car won't start? E420 - Mercedes-Benz Forum
Mercedes-Benz Forum Mercedes-Benz Forum Header Right

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help

BenzForum.com is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 08-24-2005, 12:46 PM   #1
LeGenDz
Junior Member
 
Join Date: Aug 2005
Posts: 5
Send a message via AIM to LeGenDz
Car won't start? E420

Our 1995 E420 just randomly stopped starting. We drove to our destination came back to the car to leave approx 2 hours later and it would not start. The battery and everything seems to be fine. All the electronics work, it just won't turn over. Any ideas?

PHAEDRUS242 has already helped and suggested changing my Fuel Pump Relay and Overvoltage Protection Relay, just wanted to see if there were more people out there that had experienced the same thing..
LeGenDz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-24-2005, 01:02 PM   #2
LeGenDz
Junior Member
 
Join Date: Aug 2005
Posts: 5
Send a message via AIM to LeGenDz
Another thing I forgot to mention. The ABS light came on on our way to our destination right before we turned the car off for the last time if that has to do with anything.

Does anyone know where I can get hold of a OEM factory manual paper or CD?
LeGenDz is offline   Reply With Quote
Old 08-24-2005, 01:48 PM   #3
ajcrowe
Senior Member
 
ajcrowe's Avatar
 
Join Date: Dec 2002
Location: Atlanta, GA
Posts: 454
Not sure if this is your problem, but a common electrical problem that will cause the ABS light to come on is a bad voltage regulator. You might want to check to see if the voltage regulator is putting out enough to keep the battery fully charged.
ajcrowe is offline   Reply With Quote
Old 08-24-2005, 02:19 PM   #4
LeGenDz
Junior Member
 
Join Date: Aug 2005
Posts: 5
Send a message via AIM to LeGenDz
Quote:
Originally Posted by ajcrowe
Not sure if this is your problem, but a common electrical problem that will cause the ABS light to come on is a bad voltage regulator. You might want to check to see if the voltage regulator is putting out enough to keep the battery fully charged.
Well we had a brand new battery put in the same day it happened and it didn't change anything
LeGenDz is offline   Reply With Quote
Old 11-27-2005, 12:25 AM   #5
vytamenc
Junior Member
 
Join Date: Nov 2005
Posts: 24
THERE IS A CONTROL MODULE CALED THE BASE MODULE IN THE CONTROL UNIT BOX CHECK THE FUSES ON THE TOP OF IT. IS THE CAR CRANKING IF NOT TRY TO START THE CAR IN NEUTRAL THEN LOCK AND UNLOCK THE CAR. DO YOU HAVE AN AFTERMARKET ALARM THE ATA MAY NOT BE LETING THE CAR TO START ALSO THERE ARE SO MANY THINGS IT MAY BE EVER A STARTER
vytamenc is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 07:08 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide