My E320 doesn't recognize my key - Mercedes-Benz Forum
Mercedes-Benz Forum Mercedes-Benz Forum Header Right

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Mercedes-Benz Sedans/Wagons

BenzForum.com is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 10-02-2005, 06:52 PM   #1
MyNewE320
Junior Member
 
Join Date: Oct 2005
Posts: 1
My E320 doesn't recognize my key

Hi everyone, I'm really new to the mercedes scene. I actually picked up one that was flooded, but got an amazing deal on it. Now I'm trying to get it working.

My problem is when I put in my smartkey the car won't start, actually it seems like it won't recognize it at all. When the key is in I hear the steering wheel unlock and the speedometer display illuminates with the current temp and mileage. Most of the electronics work and whatnot, everything that I've found not to be working is electric motors that were killed by the flood.

Both batteries (main in the trunk, and backup under the hood) were dead and replaced. I have done a weeks worth of reading here and all over the internet and cannot find the answer to this. Does the smartkey code need to be re-synced with the car? Could one of the computers have died?

Thank You in advance for everyone's help and support, getting this benz to run will be a tough task, but I believe I can do it.
__________________
2004 Mercedes E320
MyNewE320 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-09-2005, 07:13 AM   #2
mbenzoi
Junior Member
 
Join Date: Aug 2005
Posts: 26
smart key? the chip card like key? if it is, then its the keyless go. right? whats the message on the instrument cluster? i have experienced this one and replacing the ESM(electronic selector module) solved it. but cant decide right away coz i haven't gathered much info about the situation. better have it checked using the car scanner. this things about keyless go are so weird sometimes.
mbenzoi is offline   Reply With Quote
Old 10-19-2005, 05:38 PM   #3
e30mpower
Junior Member
 
Join Date: Oct 2005
Location: south carolina
Posts: 1
No, the Smart Key and Keyless Go are different things. The Smart Key is what was introduced on the 98 or 99 E-Class, no flip-out metal key, just a laser and a removable valet metal key.

Have you tried this valet key?

You'll have to order a new Smart Key from the dealer, which is quite expensive. MB is perpetually trying to answer the questions that no one has asked. Hence, an over-complicated ignition system that does away with actual keys in favor of a more secure laser.
__________________
Benjamin K. Earle
Charleston, SC
1999 ML430
1997 E420

RIP: 1995 S320, 1998 S600
e30mpower is offline   Reply With Quote
Old 10-19-2005, 10:18 PM   #4
Zewerr
Veteran Member
 
Join Date: Oct 2005
Posts: 678
I'm guessing it's a 211. Anyway, make sure your batteries are good in your key. Probably about 90% of customers complaints about thier keys to me are solved with new batteries. Does it lock and unlock the doors? If it does, then there's probably something internally wrong with your car, maybe your EIS or something else. Is it cranking when you try to start it? If your doorlocks don't work, try resynchronizing the key by doing this. Insert key in the ignition. Turn key to position 2. Turn off car and remove key. Hold down the lock button and simultaniously press the unlock button 5 times. Then release both buttons and press either the unlock or lock button once. See if that resynchronizes it. I may be backwards on the lock and unlock button though. It's hard to remember when I don't have a key in my hand.
Zewerr is offline   Reply With Quote
Old 06-08-2010, 10:11 AM   #5
brownmal
Junior Member
 
Join Date: Jun 2010
Vehicle: 1997 E420
Posts: 3
If you choose to buy a new keyless entry, don't use USKeyless. They are HORRIBLE! I ordered from them . They didn't even ship the part for over a month after purchase despite numerous calls/emails. They were eager to respond until they got paid, then NOTHING. They won't answer phone or return e-mails. Their installation instructions are the worst I have ever seen. It says something like "Choose the brown wire" when there is over 100 brown wires. They are NEVER available for assistance even though they claim assistance available (and website says avail even on the weekends for assistance). Now it has been 3 months, my car still has the floorboard tore up awaiting a PROMISED e-mail with pictures, but nothing. I have asked for a refund, but they won't respond. STAY AWAY from USKeyless!
brownmal is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Mercedes-Benz Sedans/Wagons


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 07:56 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide