94 E420 high idle cold than - Mercedes-Benz Forum
Mercedes-Benz Forum Mercedes-Benz Forum Header Right

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help

BenzForum.com is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 12-05-2012, 06:27 AM   #1
sthomen
Junior Member
 
Join Date: Dec 2012
Vehicle: 94 E420
Location: texas
Posts: 8
94 E420 high idle cold than

What is this problem, high idle,1300, than warms up it fluctuates 1300-800 every second

All I did is put good gas, than I noticed it. all vac lines look good, I have no check engine lite on.

Last edited by sthomen; 12-05-2012 at 12:44 PM. Reason: more info
sthomen is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-05-2012, 06:38 AM   #2
eric242340
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: S320 W220/Zotye 1.3
Location: Jiangsu province China
Posts: 1,168
You do not give much information or history to this problem but the biggest cause of this is a vacuum leak.
__________________
ERIC
eric242340 is offline   Reply With Quote
Old 12-05-2012, 12:45 PM   #3
sthomen
Junior Member
 
Join Date: Dec 2012
Vehicle: 94 E420
Location: texas
Posts: 8
All vac is good
sthomen is offline   Reply With Quote
Old 12-05-2012, 09:09 PM   #4
eric242340
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: S320 W220/Zotye 1.3
Location: Jiangsu province China
Posts: 1,168
Quote:
Originally Posted by sthomen View Post
All vac is good
How did you test for vacuum leaks?
__________________
ERIC
eric242340 is offline   Reply With Quote
Old 12-06-2012, 03:15 AM   #5
sthomen
Junior Member
 
Join Date: Dec 2012
Vehicle: 94 E420
Location: texas
Posts: 8
Eyes, and ears. Is there a other way.
sthomen is offline   Reply With Quote
Old 12-06-2012, 03:21 AM   #6
eric242340
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: S320 W220/Zotye 1.3
Location: Jiangsu province China
Posts: 1,168
Get a can of carb cleaner spray and start the engine from cold and spray small amounts over the vacuum area's such as manifold gaskets/vacuum pipes/fuel injectors etc and if there is a leak you will see and hear the difference straight away. Be careful not to spray this onto an hot exhaust as it is flamable.
__________________
ERIC
eric242340 is offline   Reply With Quote
Old 12-07-2012, 12:42 PM   #7
sthomen
Junior Member
 
Join Date: Dec 2012
Vehicle: 94 E420
Location: texas
Posts: 8
Quote:
Originally Posted by eric242340 View Post
Get a can of carb cleaner spray and start the engine from cold and spray small amounts over the vacuum area's such as manifold gaskets/vacuum pipes/fuel injectors etc and if there is a leak you will see and hear the difference straight away. Be careful not to spray this onto an hot exhaust as it is flamable.
OK did that nothing when it starts cold the rpm is 1000 - 1300ish than in about 4min the idle retards down to norm idle than up to 1000s. the change continues till you shut it off. the changes are intermitents in seconds. its a cycle the sounds like something it forcing idle down. This car has 145k, and has not been altered in any way. all factery.
sthomen is offline   Reply With Quote
Old 12-07-2012, 06:25 PM   #8
eric242340
Super Moderator
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: S320 W220/Zotye 1.3
Location: Jiangsu province China
Posts: 1,168
You will need to read the fault codes next, it may be the air mass meter but the codes will confirm or deny this.
__________________
ERIC
eric242340 is offline   Reply With Quote
Old 12-09-2012, 05:16 PM   #9
sthomen
Junior Member
 
Join Date: Dec 2012
Vehicle: 94 E420
Location: texas
Posts: 8
Ok, I will work on that next week. wont be driven. I did see a crack on the plactic frame that holds the wires in the mass air flow. the wires are still intact.
sthomen is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
'87 300SDL Rough, smoky idle when cold. audiblefeast Diesel Discussion 2 04-25-2011 10:27 PM
high idle / high rpms no respect Mercedes-Benz Sedans/Wagons 0 03-10-2008 07:52 PM
E420 Starter brtoconnor Mercedes-Benz Sedans/Wagons 1 11-26-2007 10:55 PM
Idle Speed is too high, plus Poor Gas Mileage. dpm802 DIY/Tech Help 1 10-17-2005 08:10 AM
? buy '97 E420 hirsel18 Mercedes-Benz Sedans/Wagons 3 05-23-2003 04:15 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 01:34 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide