09 C300 will not start - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-25-2015, 04:56 PM Thread Starter
Junior Member
 
Join Date: Nov 2015
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
09 C300 will not start

I'm having problems with my Mercedes.
Car will not start, radio, lights, lock unlock works, but will not start. This the second time it happened. Last time was a year ago.
Car has 73000mi I have extended warranty but dealer it's too busy and will not be able to take it till December 4th.
Any advise?
Omar is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-26-2015, 04:15 AM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,870
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Does the engine turn over but not fire or nothing happens at all in the key run position?

ERIC
eric242340 is offline  
post #3 of 4 Old 11-26-2015, 10:36 AM Thread Starter
Junior Member
 
Join Date: Nov 2015
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
It sounds like it's going to start, but kills it right away. I have been reading and it all points out to the eis. But I would not know for sure. The good thing is that I when I bought it I also got the extended warranty which cover pretty much all except the normal wear stuff. Break pads rotors tires etc.
The dealer will be able to work on it till December 4! Good thing I have another vehicle. I will post a detail report of what the dealer tells me, so other users can be aware of thing like this.
I notice people just report the issues, but very seldom they say what the problem was.
Omar is offline  
 
post #4 of 4 Old 11-27-2015, 07:18 AM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,870
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
EIS is possible but from the symptoms I would say it is unlikely, when the EIS gives up then nothing happens in the run position sometimes and most other times it will start normally.

If your no start happens with a hot engine, the crankshaft position sensor is more likely. With a cold engine well that is another matter.

ERIC
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Mercedes-Benz Sedans/Wagons > C Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 C300 won't start scolville General Mercedes-Benz 2 04-30-2013 04:31 PM
2009 C300 immobilized. scolville DIY/Tech Help 2 03-09-2013 06:41 PM
From a 300C to a C300. White_C300 Off Topic/New Member Introductions 4 05-07-2012 10:31 PM
Servicing C300 jappel2 Mercedes-Benz Sedans/Wagons 1 11-22-2008 10:24 PM
c300 warren4709 Mercedes-Benz Sedans/Wagons 0 03-10-2008 02:45 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome