CLK320 Hi Speed Braking in turns - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 11-01-2017, 01:03 AM Thread Starter
Junior Member
 
Join Date: Nov 2017
Vehicle: 2002 CLK320
Location: USA- SoCal- Los Angeles, San Diego, Palm Springs
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
CLK320 Hi Speed Braking in turns

HELP! My CLK320 brakes at Freeway speeds when I enter long sweeping turns above 60 mph. When driving on the highway, entering a right only sweeping turn the yellow triangle on the dash speedometer in center with exclamation point starts to flash, then the car begins to slow down. When I push on the accelerator, nothing. At 80-90 mph it will slow down to 60 - 70 mph until back in the straight away again, then it continues to perform in the amazing traditional Mercedes expected performance. It does not do it when going left, only right. I have researched that there are three possible components that are causing it. The ESP YAW Turn Rate Sensor P/N: 0265005230, the ABS YAW Turn Rate Accelerator Sensor P/N: 0005426518, or the Brake Light Switch. I really hate to do the process of elimination in replacing all three if someone has had this problem before and can tell me which one it most likely is, or if it might be a completely different problem all together. I also have a ML320, SLK320, and C320, but none of them have had this problem yet. Thanks everyone for your input, it will be appreciated!
$Mercedes4Life is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-01-2017, 01:26 AM
Administrator
 
RedLiner's Avatar
 
Join Date: Jun 2009
Vehicle: 1993 SL500, 1998 SL500 pano top, 2005 ML270cdi.
Location: Spain and Gibraltar
Posts: 836
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
More information needed!

To help us help you can you please complete your user profile giving the year/s and model/s of your car/s, also a location, just a country or state is sufficient.
At the top of the page there is a bar with Home Forums etc. on this bar is User CP go there and put in this important information.

No trees were harmed creating this message, however some electrons were very inconvenienced.
RedLiner is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > CLK/CLS/CL Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1997 C230 Won't start, nothing happens when key turns Mr. CJ DIY/Tech Help 2 11-18-2010 10:25 AM
W168A160 it turns off pondito DIY/Tech Help 0 07-03-2010 01:02 AM
2004 c240 transmission leak turns into big trouble.. HELP!!!! sandra_uta_slg Mercedes-Benz Sedans/Wagons 1 01-08-2009 01:12 PM
two full turns cracker928 Diesel Discussion 2 07-15-2003 09:42 AM
6 speed manual or 5 speed automatic? Ted Payton DIY/Tech Help 3 02-18-2003 02:55 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome