1999 A170 cdi "EPC" light and cutting out - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-16-2013, 02:37 PM Thread Starter
Junior Member
 
Join Date: Apr 2013
Vehicle: 1999 a170 Cdi
Location: Uk
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
1999 A170 cdi "EPC" light and cutting out

Hi

I have a 1999 A170 W168. I have recently gone and taken it for a drive. I went along. Steady at 60 mph. No over heating no silly driving. All of a sudden the car had lost power. As if it was stalling. ( it's a auto. ). The car came to a stop ad the EPC light came on. The car started and ran fine after. Apon looking into the problem online I had replaced the fuel filter and cleaned the EGR. went to take it out and it was nippier with the EGR cleaned but the same problem came. I later went to a garage and scanned it. The only code that came back was p1187. Something with fuel rail pressure.

I need to know what can cause the problem and what to look out for and how to cheaply solve the problem.

More info can be given on request

Thanks guys


Sent from AutoGuide.com Free App
Joshuaconroy is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 07-25-2014, 09:58 AM
Junior Member
 
Join Date: Jul 2014
Vehicle: A170
Location: Croatia
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hey, sorry to bump an old thread, but i have the same problem
how did you fix your problem?
en3rgy is offline  
post #3 of 3 Old 08-13-2014, 04:47 AM
Raj
Junior Member
 
Raj's Avatar
 
Join Date: Aug 2014
Vehicle: MUV Car
Location: jaipur
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Most of time a diesel injector come with a high leak off rate. Sometimes it can be so difficult to identify the faulty injector if the fault is intermittent.
Raj is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Diesel Discussion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
C280 "SRS" Light Staying ON tvwxdude Mercedes-Benz Sedans/Wagons 0 07-12-2007 12:18 AM
1999 ML430 "ticking" sound in return air vent jkkj M/G/GL/GLK Class 2 04-24-2007 07:02 AM
94 E320 "Check Engine" light lynx2ii77 DIY/Tech Help 1 11-12-2004 12:41 PM
94 E320 "Check Engine" light lynx2ii77 DIY/Tech Help 0 11-12-2004 12:06 PM
Removing "C230" and "Kompressor" letters Blake P Mercedes-Benz Sedans/Wagons 13 08-25-2003 12:59 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome