New member and in need of help 84 300D fuel issue - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-08-2017, 11:52 PM Thread Starter
Junior Member
 
Join Date: Apr 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
New member and in need of help 84 300D fuel issue

Hello all,
I am new here but I have read some great advice on this forum so I am looking for guidence. I inherited a 1984 300 D turbo Mercedes from my Mother-in-law. We drove the car for years, great little car but in the past six months I have experienced power loss and even had the engine quit on me. I found two issues, first I noticed a leak around the old primer pump so I replaced it with a Bosch pump. I thought that did the trick but a few days later I had the same issue. Next I replaced all of the filters under the hood. Still had the same problem but it seemed intermittent. I decided to clean or replace the fuel sock at the tank and while doing that I noticed a split in the fuel line from the tank so I replaced the sock and the fuel line, refilled the tank, and primed the system. The car ran great, I took it to dinner about twenty miles from home, came back after dinner and had no issues. The next day I headed to work and before I could get out of the development the car died after loosing power. Is it possible that I did not bleed the air out of the system? This problem has me stumped so I would appreciate advice on possible problems and solutions. Thanks in advance.
Cdzink is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Diesel Discussion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1987 mercedes sl 560 fuel issue fcantafio DIY/Tech Help 1 05-28-2014 09:50 AM
Sluggish 300D / recent issue lmwjerry Diesel Discussion 1 10-30-2013 08:41 PM
2001 ML320 fuel sensor issue s.tutty1976 M/G/GL/GLK Class 0 08-06-2013 12:16 PM
Shifting issue on my 76 300D matthend Diesel Discussion 3 02-22-2005 12:01 PM
@003 CL55 AMG start/fuel issue mcash DIY/Tech Help 2 06-17-2003 08:41 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome