1985 300 TD Coupe Electrical A/C, Tach, Horn not working - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-25-2018, 05:55 AM Thread Starter
Junior Member
 
Join Date: Feb 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Question 1985 300 TD Coupe Electrical A/C, Tach, Horn not working

Greetings;
I have a 1985 300 TD. Was stored in garage for winter. Went to start and battery was weak so jumped to start. Heard a pop sound. Now the A/C, Tachometer, horn stopped working. Checked main fuse block under hood driver side and all are good. I have heard there is another relay or fuse but unable to locate. Called local MB dealership parts guy and he did not have a clue.
Any one familiar with this issue?
colemape is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Diesel Discussion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1982 300TD 123 tach not working buckwill Diesel Discussion 1 02-28-2014 11:15 PM
1985 300d odometer quit working jessiecreasy Mercedes-Benz Sedans/Wagons 2 10-29-2009 01:39 PM
W124 tach and AC not working Tasma Diesel Discussion 4 08-17-2009 03:58 PM
1985 300TD Tach. StraightAway Diesel Discussion 2 03-26-2004 02:43 PM
Dash electrical problem '83 300 td mark Diesel Discussion 1 11-03-2003 05:42 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome