Odd noise at warm idle - Mercedes-Benz Forum
 1Likes
  • 1 Post By chargerpower
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 04-29-2019, 03:36 PM Thread Starter
Junior Member
 
Join Date: Aug 2018
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Odd noise at warm idle

When my '81 W123 240D is thoroughly warmed up (not when it's first started) it makes an intermittent clicking or chirping noise. It's coming from the area of the alternator and when you squirt water directly on the alternator belt , the noise stops until the belt dries off. I replaced the alternator and still hear the noise. The only other thing on that belt is the water pump which i replaced about a year ago. The belt also looks good. Any theories? Thanks.
cult colt is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-30-2019, 09:40 AM
Administrator
 
Join Date: Dec 2016
Vehicle: 1999 ML430, 2000 ML320, 2005 E500 4matic wagon
Location: Wisconsin
Posts: 101
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Was it a new or reman pump installed?

Also what brand of pump was installed?
Noodles is offline  
post #3 of 4 Old 05-03-2019, 09:10 AM
Junior Member
 
Join Date: Mar 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Look and see if the bottom of the water pump/crankshaft/alternator pulley is shiny at the bottom like clean metal. If it is the belt is bottoming out due to wear on the pulley itself and that will cause the noise you describe. You will need to replace the offending pulley or you could get a larger section belt.
Noodles likes this.
chargerpower is offline  
 
post #4 of 4 Old 05-04-2019, 11:03 PM
Junior Member
 
Join Date: May 2005
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by cult colt View Post
When my '81 W123 240D is thoroughly warmed up (not when it's first started) it makes an intermittent clicking or chirping noise. It's coming from the area of the alternator and when you squirt water directly on the alternator belt , the noise stops until the belt dries off. I replaced the alternator and still hear the noise. The only other thing on that belt is the water pump which i replaced about a year ago. The belt also looks good. Any theories? Thanks.
I think you answered your own question...squirt water on the belt and noise goes away...got to be the belt.

I had this exact same issue with my '78 308. The clicking sound was actually the belt snapping because it was stretched and loose. Mine also made a squealing (could be described as chirping) sound because the belt was glazed. Belts are sometimes hard to tell if they need replacing. Make sure it is tensioned properly and/or replace the belt.
hanknum is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Diesel Discussion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd Knecht Fuel Filter Housing on 1973 220 Diesel trojoshua Diesel Discussion 1 07-06-2017 02:50 AM
odd problem RichardC DIY/Tech Help 1 01-25-2015 02:37 AM
Odd Air Conditioner Problem Troutman DIY/Tech Help 0 09-30-2007 07:32 AM
Odd electrical prob on '84 W123 JeeperDon Diesel Discussion 1 06-14-2007 01:29 PM
1992 s500 starts fine, rough idle when warm rennym Mercedes-Benz Sedans/Wagons 2 08-09-2005 07:09 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome