1997 C230 Won't start, nothing happens when key turns - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 11-13-2010, 05:16 PM Thread Starter
Junior Member
 
Join Date: Nov 2010
Vehicle: 1997 and 2006 C230
Location: NC
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
1997 C230 Won't start, nothing happens when key turns

Just bought my 2nd C230 today, a 1997 (have had an '06 for 3yrs). But I am having troubles getting the C230 started. I purchased at auction, so you never know history, but car looks great, has 100k miles and I purchased as a fixer upper since it didn't run when I bought it. Here is my problem:

When I turn the key, nothing at all happens, by nothing, I mean NOTHING, no clicks, no dimming of headlights, etc. Here is also what does and doesn't work.

*I have just installed a brand new battery.
*ALL fuses, engine compartment (left and right) and trunk have been looked over 4 times and are all good.
*Main cooling fan runs when ignition ignition is turned on, but nothing else.
*Instrument cluster does not light up-hazard lights all work propery and red triangle flashes.
*The interior lights, headlights, trunk, reverse, and all signal/hazard lights work fine.
*Horn works
*Central locking system works (all functions-manual with key, outside car, button inside, and trunk, red/green)
*Only one window control-pass. front-works, I hear click for all others in trunk fuse panel.
*Speedo/Tach Gauges do not light up.
*Radio doesn't turn on at all, no message on screen.

If anyone knows where I might find the holy grail of how to get this 97 C230 started, let me know. I'd love to be able to hear it run. Or, if you have any suggestions for any of the other items, I am all ears.



Thank you in advance for your reply.

Last edited by Mr. CJ; 11-13-2010 at 09:03 PM.
Mr. CJ is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 11-18-2010, 08:14 AM Thread Starter
Junior Member
 
Join Date: Nov 2010
Vehicle: 1997 and 2006 C230
Location: NC
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Actron OBD-II 9175 code reader does not read any codes when hooked up and ignition turned on, there is a communications error. (The reader works fine on my other cars.)
Starter was removed and tested, operates fine. Wires look good.
All wires under dash panel looks fine.

What should I try next? Here is a short description of problem.

Has new battery, all central locking, headlights, and horn works. Insert key into ignition, turn, cooling fan comes on, turn to run, nothing at all. No beeps, no starter even attempting to crank.

Any thoughts?
Mr. CJ is offline  
post #3 of 3 Old 11-18-2010, 11:25 AM
Administrator
 
RedLiner's Avatar
 
Join Date: Jun 2009
Vehicle: 1993 SL500, 1998 SL500 pano top, 2005 ML270cdi.
Location: Spain and Gibraltar
Posts: 853
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
If you bought the car at auction It may not have the correct programme in the ignition key!

Is there is any history with the car e.g. is it a recovered stolen car?
New keys can be bought from eBay, they may fit the lock and turn, but they won't start the car. (DAS system)

I would start by checking out if the key is correctly programmed. to do this you will have to go to a Mercedes dealer and take proof of ownership of the car.

If Mercedes have to supply a new programmed key it may cost $200 plus.

Last edited by RedLiner; 11-18-2010 at 11:26 AM. Reason: additional info
RedLiner is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1997 C class Key problem...HELP! ukgun777 DIY/Tech Help 1 06-09-2010 04:26 AM
steering wheel locked, key will not turn, cannot start car! horse2 DIY/Tech Help 6 09-15-2009 12:05 PM
New 1997 C230 Owner eroy Mercedes-Benz Sedans/Wagons 2 06-23-2004 10:20 AM
Need advice on a 1997 C230 RDM3 Mercedes-Benz Sedans/Wagons 0 04-04-2004 09:31 PM
E320 1997 STALLING AFTER COLD START! Si320a/garde Mercedes-Benz Sedans/Wagons 1 02-16-2004 11:06 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome