Mercedes-Benz Forum

Mercedes-Benz Forum (https://www.benzforum.com/forum/)
-   DIY/Tech Help (https://www.benzforum.com/forum/diy-tech-help/)
-   -   Airmatic Issue Need Help (https://www.benzforum.com/forum/diy-tech-help/17603-airmatic-issue-need-help.html)

ELJones 01-13-2013 06:27 AM

Airmatic Issue Need Help
 
I have a 2001 S-500 with airmatic. I jacked up the front end to change the tire and now both front struts are down and will not re-inflate. I have tried several things and what I am interested in now is this. Is their a way to manually inflate the struts so that I will know that they are not blown and also so that I can move the car.

Thanks,

ELJones

eric242340 01-13-2013 06:51 AM

Jack the front up again until the weight is off the front but the wheels are still in contact with the ground and run the engine again for a few minutes and slowly lower the car, bit by bit until the weight is back on the wheels. Once it is down on the wheels push the airmatic switch to raise the car and wait.

ELJones 01-13-2013 09:25 AM

Did that...
 
Thanks Eric, I did that but it did not work. I have also cleaned the sams/cans and made sure they were dry. I also replaced the relay. I did notice that the pump works when the relay is triggered manually but otherwise it does not. I have checked and replaced all bad fuses as well. Is their a way to disconnect the airline from the top of the struts and pump them up directly?

eric242340 01-13-2013 09:31 AM

Quote:

Originally Posted by ELJones (Post 57965)
Thanks Eric, I did that but it did not work. I have also cleaned the sams/cans and made sure they were dry. I also replaced the relay. I did notice that the pump works when the relay is triggered manually but otherwise it does not. I have checked and replaced all bad fuses as well. Is their a way to disconnect the airline from the top of the struts and pump them up directly?

You cannot pump them up directly. Why did you change a tyre? Hit a pothole or something like that? If so you may have damaged/lost the ride height sensor linkage.

ELJones 01-13-2013 03:51 PM

I had a flat. All of the front end height linkage seems to be in place. If I jack up the car the 'car too low' goes out. When lowered it comes back on so the height indicators are working. Any other suggestions? On the driver side, under the hood, just behind the strut their is some type of valve that clicks really fast when the pump is running. Is it supposed to do that? Its only on the driver side.

eric242340 01-13-2013 11:33 PM

Quote:

Originally Posted by ELJones (Post 57967)
I had a flat. All of the front end height linkage seems to be in place. If I jack up the car the 'car too low' goes out. When lowered it comes back on so the height indicators are working. Any other suggestions? On the driver side, under the hood, just behind the strut their is some type of valve that clicks really fast when the pump is running. Is it supposed to do that? Its only on the driver side.

Not sure which valve you mean, does it have two vacuum pipes connected and an electrical connector?

ELJones 01-22-2013 04:39 AM

Quote:

Originally Posted by eric242340 (Post 57968)
Not sure which valve you mean, does it have two vacuum pipes connected and an electrical connector?

Sorry for the delay in replying. Here are some pics of the parts, their are actually 2 parts I cannot identify, the one with 'MOT` stamped on it is the one that is clicking very fast. I've posted the pictures on my website.

http://www.eljones.com/s500.html

eric242340 01-22-2013 04:49 AM

1 Attachment(s)
Quote:

Originally Posted by ELJones (Post 57994)
Sorry for the delay in replying. Here are some pics of the parts, their are actually 2 parts I cannot identify, the one with 'MOT` stamped on it is the one that is clicking very fast. I've posted the pictures on my website.

http://www.eljones.com/s500.html

The one that says MOT on it is the purge valve and this is supposed to tick as it is taking fumes from the fuel tank and feeding those fumes into the inlet manifold, nothing to do with airmatic.

I cannot view the pics as I cannot connect to your site, I am in China and we have a large firewall that blocks many sites. You can upload the pics here very easy.

When posting a reply scroll down a tad and click on manage attachments, a window will open and you can choose to upload from your computer or from a url.

ELJones 01-22-2013 05:00 AM

3 Attachment(s)
Thanks, here are the pics. Is their a cam/sam that can be replaced that controls the front airmatics?

eric242340 01-22-2013 05:21 AM

Quote:

Originally Posted by ELJones (Post 57996)
Thanks, here are the pics. Is their a cam/sam that can be replaced that controls the front airmatics?

First two pics are the lateral accelleration sensors and the last is the purge valve, none of them have anything to do with airmatic. Now does the compressor switch on? to hear it you will have to put your ear to the front bumper passengers side.


All times are GMT -6. The time now is 05:48 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© AutoGuide

 
For the best viewing experience please update your browser to Google Chrome