97 S320 Oil in the Cooling system but... - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 03-23-2013, 07:20 AM Thread Starter
Member
 
Join Date: Apr 2010
Vehicle: 1985 300sd
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
97 S320 Oil in the Cooling system but...

Not in the oil Pan.

All-

1997 S320 with Oil in the radiator and cooling system. normally would suspect a head gasket problem but there is no water in the Oil pan.

I did replace the water pump about 4 months ago.

Has anyone seen this? Not opposed to replacing head gasket but want to see if anyone:

1.) had a similiar experience
2.) had an alternative causes.

Oh, if somone has the procedure for replacing the head gasket, I would appreciate a link...

Many Thanks

Last edited by jfarmer64; 03-24-2013 at 10:34 AM.
jfarmer64 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 03-26-2013, 03:52 AM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,865
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
I seem to be the only person answering questions on this part of the forum and sadly I know little of this model, but does it have an oil cooler on the side of the oil filter housing? I believe this is the 104 inline six engine.

ERIC
eric242340 is offline  
post #3 of 9 Old 03-26-2013, 05:34 PM Thread Starter
Member
 
Join Date: Apr 2010
Vehicle: 1985 300sd
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
No Oil cooler next to oil filter.

Is in line 6, oil filter canister type, mount top on drivers side near firewall
jfarmer64 is offline  
 
post #4 of 9 Old 03-26-2013, 10:57 PM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,865
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
OK, are you sure it is engine oil getting in there and not transmission fluid? The transmission oil cooler is part of the radiator.

ERIC
eric242340 is offline  
post #5 of 9 Old 03-27-2013, 04:56 AM Thread Starter
Member
 
Join Date: Apr 2010
Vehicle: 1985 300sd
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
It is not transmission fluid. Tranny fluid is red this is brown.

Same color as coffee with heavy cream
jfarmer64 is offline  
post #6 of 9 Old 03-27-2013, 05:06 AM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,865
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Quote:
Originally Posted by jfarmer64 View Post
It is not transmission fluid. Tranny fluid is red this is brown.

Same color as coffee with heavy cream
It would be the same indicator with old transmission fluid, with age transmission fluid could look as black as engine oil and show the same effect when mixed with coolant. Have you checked both transmission fluid level and engine oil level and what is the colour of the transmission fluid on the dipstick?

ERIC
eric242340 is offline  
post #7 of 9 Old 03-28-2013, 05:22 PM Thread Starter
Member
 
Join Date: Apr 2010
Vehicle: 1985 300sd
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Their is no Transmission Dipstick. The Cover says MB Service Shop only
jfarmer64 is offline  
post #8 of 9 Old 03-28-2013, 09:07 PM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,865
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Quote:
Originally Posted by jfarmer64 View Post
Their is no Transmission Dipstick. The Cover says MB Service Shop only
Get a length of wire and dip the tranny, you only need to see the colour of the fluid, if red/brown then we have an head gasket job and if a milky white then it is the radiatior.

ERIC
eric242340 is offline  
post #9 of 9 Old 03-29-2013, 04:27 PM Thread Starter
Member
 
Join Date: Apr 2010
Vehicle: 1985 300sd
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks Eric, will check that out and will let you know.

I have a pretty severe oil leak in the car which is part of the u tape gasket that fits on the timing cover. I am about to post some Cam position related questions. I would appreciate your help with that as well.
jfarmer64 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
AT Cooling lines replacement geminiys M/G/GL/GLK Class 4 09-25-2007 10:05 PM
400E Cooling Problem Parkervess Mercedes-Benz Sedans/Wagons 0 12-05-2005 12:44 AM
Upgrade to navigator system in 1999 Model of S320 kuwdad Mercedes-Benz Sedans/Wagons 2 06-01-2004 05:29 PM
89 300e cooling luvthemerc Mercedes-Benz Sedans/Wagons 1 12-31-2003 10:02 AM
Cooling system problem roadbuzz Diesel Discussion 1 12-04-2003 09:53 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome