W210 E320 A/C Compressor problem - Page 2 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 45 Old 03-29-2015, 06:05 AM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,865
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Both pressure too high and pressure too low will shut the system down. The pressure sensor is located on the dryer.

ERIC
eric242340 is offline  
Sponsored Links
Advertisement
 
post #12 of 45 Old 04-06-2015, 12:55 AM Thread Starter
Member
 
Join Date: Mar 2015
Vehicle: 1997 Mercedes Benz E320
Location: Los Angeles, CA
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
(Thread Starter)
Okay Eric since you have helped me throughout all of this I decided it would be fair to update you with what has been going on. At this point me and the mechanic are doing trial and error replacements to single out the issues with the A/C. Now we have replaced the pressure switch and the evap temp switch just to replace any sensors that may be tripping off the system. That didn't work so we got another mechanic in to check it out. He was stumped but diagnosed the compressor as the issue. We got a compressor from a working E320 from the same year, 97, and replaced it. That didn't work either but didn't upset me to much as I only paid 60 bucks for the compressor. So now after eliminating all of those possibilities I'm starting to thing the actual control module is our issue. Because it was only AFTER I did the W210 to W140 regulator swap. I think it could have tripped something out in the controls. Anyway going to see another mechanic that works with these kinds of issues and will post the solution. In the mean time, I still have to drive that darn BMW to keep cool. So sad. They never realized what true performance was.
sean4040 is offline  
post #13 of 45 Old 04-13-2015, 06:42 PM
Junior Member
 
Join Date: Apr 2015
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Nice thread, new member permission join this discussion
inamoto is offline  
 
post #14 of 45 Old 04-13-2015, 08:50 PM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,865
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Quote:
Originally Posted by inamoto View Post
Nice thread, new member permission join this discussion
Permission granted, all contributions gratefully accepted.

ERIC
eric242340 is offline  
post #15 of 45 Old 04-13-2015, 08:52 PM Thread Starter
Member
 
Join Date: Mar 2015
Vehicle: 1997 Mercedes Benz E320
Location: Los Angeles, CA
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
(Thread Starter)
You'd be surprised if I told you the A/C still isn't fixed -_-
sean4040 is offline  
post #16 of 45 Old 04-13-2015, 08:56 PM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,865
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Quote:
Originally Posted by sean4040 View Post
You'd be surprised if I told you the A/C still isn't fixed -_-
What are the low and high pressure readings with engine running and A/C on?

ERIC
eric242340 is offline  
post #17 of 45 Old 04-13-2015, 08:58 PM Thread Starter
Member
 
Join Date: Mar 2015
Vehicle: 1997 Mercedes Benz E320
Location: Los Angeles, CA
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
(Thread Starter)
I'm not sure on how to check that, but I recently had it topped off by an A/C shop to check to see if that was my problem and it wasn't. But I left the freon in
sean4040 is offline  
post #18 of 45 Old 04-13-2015, 09:00 PM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,865
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
You will need the pressure guages attached to the system to read the pressures, reason I mentioned this is that the high pressure may be too high due to a blocked/broken expansion valve. A local workshop of any car repair type will have the guages.

ERIC
eric242340 is offline  
post #19 of 45 Old 04-13-2015, 11:08 PM Thread Starter
Member
 
Join Date: Mar 2015
Vehicle: 1997 Mercedes Benz E320
Location: Los Angeles, CA
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
(Thread Starter)
I've heard something about the expansion valve mentioned before on a forum. How much does it cost to replace that?
sean4040 is offline  
post #20 of 45 Old 04-14-2015, 01:57 AM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,865
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Quote:
Originally Posted by sean4040 View Post
I've heard something about the expansion valve mentioned before on a forum. How much does it cost to replace that?
I could not say how much as I live in China but I know the valve is not expensive.

ERIC
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
w210 E320 window issues! Grindin' Mercedes-Benz Sedans/Wagons 2 02-21-2011 01:11 PM
Bilstein Hd Shocks Mercedes W210 E320 E320 2000 Opale Mercedes-Benz Sedans/Wagons 2 10-28-2007 01:24 PM
Anyone parting a W210 - E320 out? Need some electrical parts gts95 Mercedes-Benz Sedans/Wagons 0 08-25-2005 08:40 AM
w210 mirror problem ninety9cents Mercedes-Benz Sedans/Wagons 1 05-03-2005 08:04 AM
Looking for W210 E320 or E55 AMG bodykits Nikita For Sale, Trade & Wanted 0 08-01-2004 11:56 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome