2013 ML350 Major Transmission Problem - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-20-2017, 11:58 AM Thread Starter
Junior Member
 
Join Date: Sep 2017
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
2013 ML350 Major Transmission Problem

My 2013 ML350 with 54,000 miles is having transmission problems. After taking off from a stop sign, there was a somewhat loud "POP" and then the car wouldn't move. It wouldn't shift into drive or reverse. It was pushed into a parking lot and after putting it into park, I found that it still rolled. I had to put on the emergency brake so it wouldn't roll away. The car engine kept running the whole time. When trying to go into park or reverse there is a loud clicking sound. Not really grinding sounds, more of a harsh click. Trying to go the drive, there is no sound. It is at the dealer. They say they are backed up for 2 weeks. They said a new transmission might cost $10K to $15K. It might be a couple of months before I get my vehicle back. Any one had a similar problem? Any one had to replace a transmission? If so, how much was it including labor?
Thanks in advance for any help or advice.
bennynaas is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mercedes ml350 2006 problem Michael Collins General Mercedes-Benz 4 12-12-2016 05:46 AM
FS:2013 Benz ML350 Control Unit "Stereo" maudc5 For Sale, Trade & Wanted 0 02-11-2013 11:48 PM
ML MAJOR lights on dash problem, wont shift out of 1st gear! bergfurher M/G/GL/GLK Class 0 11-02-2006 08:12 PM
C240 Major Electrical Problem jakec68 Mercedes-Benz Sedans/Wagons 1 08-23-2006 10:21 PM
Transmission problem LILBLONDIE Mercedes-Benz Sedans/Wagons 2 06-25-2005 06:18 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome