300CE Fuel Pump - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 10-11-2019, 03:35 PM Thread Starter
Junior Member
 
Join Date: Oct 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
300CE Fuel Pump

Replaced both fuel pumps with new Bosch units. Replaced fuel pump relay which was shorted/burned with MB part. Engine cranks but won't start. What else might be the problem? What suggestions ? Thanks, Bill
Bilbob is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 10-12-2019, 10:28 AM
Administrator
 
Join Date: Dec 2016
Vehicle: 1999 ML430, 2000 ML320, 2005 E500 4matic wagon
Location: Wisconsin
Posts: 142
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
What year is it?
Noodles is offline  
post #3 of 11 Old 10-12-2019, 06:18 PM Thread Starter
Junior Member
 
Join Date: Oct 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
300CE fuel Pump Relay

It's a 1993 CE300 ID# ending in PB870604. Car does run if I load the MAF port with starter fluid but dies within a few seconds. How can I check power TO the relay base and power FROM relay to pumps? Relay and pumps are new. Thanks, Bill
Bilbob is offline  
 
post #4 of 11 Old 10-14-2019, 09:23 AM
Administrator
 
Join Date: Dec 2016
Vehicle: 1999 ML430, 2000 ML320, 2005 E500 4matic wagon
Location: Wisconsin
Posts: 142
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
I wish relay testers were still a common thing at parts stores.

I need to check the relay used and then I can hopefully tell you how to test it with a DVOM or make a jumper to the two correct pins that would power up the pump.
Noodles is offline  
post #5 of 11 Old 10-14-2019, 09:47 AM Thread Starter
Junior Member
 
Join Date: Oct 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
CE300 Fuel Pump

Thanks. It's a new MB relay MB#001-542-96-19 called a K27 in my MB manual. Surprisingly, that K27 number does not show up in my MB260/E300 wiring diagram which I am not sure to be the correct diagram. It's the only diagram that has the E300 designation. The manual is Mercedes Benz W124 1985-1995 which lists the 300E as being included. I'm lost! Do you know if this model has an inertia switch/fuel pump cutoff switch? Thanks, Bill
Bilbob is offline  
post #6 of 11 Old 10-15-2019, 10:04 AM
Administrator
 
Join Date: Dec 2016
Vehicle: 1999 ML430, 2000 ML320, 2005 E500 4matic wagon
Location: Wisconsin
Posts: 142
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
I do not know if there is a safety inertia switch. I should have access to some MB docs before the weekend.
Noodles is offline  
post #7 of 11 Old 10-15-2019, 02:24 PM Thread Starter
Junior Member
 
Join Date: Oct 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Fuel Pump 300CE

Thanks! I'll be anxiously awaiting your help!
Bill
Bilbob is offline  
post #8 of 11 Old 10-24-2019, 11:58 AM Thread Starter
Junior Member
 
Join Date: Oct 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
CE 300 Fuel Pump

After Noodles.
Any word yet on relay?
Thanks., Bill
Bilbob is offline  
post #9 of 11 Old 10-24-2019, 12:30 PM
Administrator
 
Join Date: Dec 2016
Vehicle: 1999 ML430, 2000 ML320, 2005 E500 4matic wagon
Location: Wisconsin
Posts: 142
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
I have what I think are the wiring diagrams. every time I try to export them as a PDF or .dxf file the drop
10% of their size. I am doing this in VA Ware on a Mac. I hope to get to a real Winderz machine as I have
been told the drivers for VM Ware Fusion are more than likely causing the problem.

From what I can tell in the circuit there is not an inertia switch, but it would not be the first time a wiring
diagram is wrong from a car maker.
Noodles is offline  
post #10 of 11 Old 10-25-2019, 01:12 PM Thread Starter
Junior Member
 
Join Date: Oct 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
CE300 FP Relay

Thanks,!
I'll be waiting. Bill
Bilbob is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome