2001 C240: Loads of problems am I alone here? - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-10-2003, 12:01 PM Thread Starter
 
Join Date: Feb 2003
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
2001 C240: Loads of problems am I alone here?

I purchased a C240 in May of 2001. Upon delivery one of the 2 keys didn't function properly (wouldn't lock or unlock doors). This was replaced and has been replaced about 5 times since. This problem has been intermittent and hard to correct. We have yet to have 2 working keys. The ABS system had to be replaced. the car was taken in for a turn signal bulb and we were told that the entire headlight assembly needed to be replaced and now we are being told that the waterpump is leaking.

What experiences have others had with this model. The dealer has given us a loaner car most everytime it is in the shop and the warranty has covered all of the repairs. My concern is post warranty. At this point I am loosing confidence in this car. My wife drives it with our 2 year old in tow. We traded in a Cadillac Eldorado for this car to get away from reliability problems only to be plagued by more.

So what have your experiences been with your C240?

bo
[email protected]
505-346-2132
beauto is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 02-16-2003, 10:27 PM
 
Join Date: Feb 2003
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
smells like a lemon.. does it taste like a lemon?

Well, I've just replaced one of my smartkeys recently (it didnt start acting up until perhaps November, after nearly 2 yrs of use). seems some of the early smartkeys have problems.

other problems:
-shorted out rear glass defroster (fixd)
-exterior bulbs keep burning out
-central vent keeps fogging up the windshield (replaced... still a bit left)
-clicking driver's seat (fixed.. but now there's some "give" when going around corners.. bah i give up)
pokerface is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome