1990 300SL Power Locks, Power Antenna, and trunck light - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 11-12-2003, 01:33 PM Thread Starter
 
Join Date: Nov 2003
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
1990 300SL Power Locks, Power Antenna, and trunck light

Hello all,

My 1990 300Sl Power Locks, Power Antenna, and trunck light stopped working all at once. I know they share the same fuse but the fuse is good and there is power at the fuse. Has any one seen this before.

Thanx Joe
joewood is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 11-12-2003, 08:04 PM
 
Join Date: Oct 2003
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
fuse

check the fuse again, and replace anyway. often the end will corrode on the old style fuses and still appear to be working as it should, but in fact isnt allowing enough current to flow. it may not be this, but its a very common thing on my end.
mbztech22 is offline  
post #3 of 3 Old 11-12-2003, 09:35 PM Thread Starter
 
Join Date: Nov 2003
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Yes, I tought about that over the weekend and changed it but the result was still the same.

Thanx Joe
joewood is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome