Problems with 1989 420SEL - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-16-2004, 08:16 PM Thread Starter
 
Join Date: Mar 2004
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Problems with 1989 420SEL

Ok so i get my uncles car and its al fine except that when driving at night teh car lights get real dim. So i decided to pull to the shulder. Put it in park and the lights get brighter. Next day i replace the alternator, jump the car and run it. drive it around and all seems fine. The next day i come home from work and the car does the same thing (lights get dim) pull to the side and charges back up. I was thinking that the alternator was defective. So my dad in the morning decides to take the benz to work. The belt on the car fell off off the alternator. Got it towed to my work and they put a new belt in. The car had trouble starting for some reason. The guy took the top cover for the air box off and got the car started. It was ideling at 1500 with was pretty high considering that it had no problems before and ideling at 800 or so. The car idles fine when it is in anything but Park and Neutral. I dunno whats up with it. I talked to a Benz specialist and he told me some steps to reset the computer or something but touching the postitive and neg. cables toghter with teh battery disconnected and then drive it. I didnt really do anything. Im new to this Benz vehicles. I dunno what is wrong or what to do. Any help would be helpful. Thanks
Azneddie is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > DIY/Tech Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome