speakers dont work - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 09-19-2005, 09:52 PM Thread Starter
 
Join Date: Mar 2005
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
speakers dont work

i have a 1993 400e with stock stereo and when in FM mode only the right side speakers work but when in AM mode all of the speakers work perfectly, i have checked the balance and fade and they are both in the middle. can anyone imageine what might have happened?
Parkervess is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 09-20-2005, 07:12 AM
 
Join Date: Dec 2003
Posts: 1,467
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hard to say. At this point I would venture to guess there is something wrong with the radio head unit itself. That is the only logical variable in this equation. If it works in one mode, then a change is made on one component and the symptom appears, logic tells us we should start there. Quite honestly, unless you can find a used unit, supplies are quite scarce (and expensive) on these radios, so it is hard to just plug one in to test. Aftermarket radios are still easy to install on the older cars. The only problem is finding one that doesn't look like Las Vegas at night when it's on (and doesn't clash horribley with the interior of the car).



PHAEDRUS242 is offline  
post #3 of 7 Old 09-20-2005, 01:14 PM Thread Starter
 
Join Date: Mar 2005
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Re:

would a head unit from another class mercedes work in my 400E if both cars were the same year?
Parkervess is offline  
 
post #4 of 7 Old 09-21-2005, 07:30 AM
 
Join Date: Dec 2003
Posts: 1,467
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
As long as it is the same unit (basically as long as it looks the same as the one you have).



PHAEDRUS242 is offline  
post #5 of 7 Old 09-29-2005, 04:55 PM Thread Starter
 
Join Date: Mar 2005
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Re:

I know this is probably a stupid question and you already told answered me but im gonna ask anyway. would a stock head unit from a 1994 E420 work?
Parkervess is offline  
post #6 of 7 Old 09-30-2005, 11:36 AM
 
Join Date: Dec 2003
Posts: 1,467
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
If it looks exactly the same as yours, it will work. If it looks different, examine the connecotrs on both. It should plug in if the connectors are the same. I haven't tried mixing radios from different years, so no personal experience.



PHAEDRUS242 is offline  
post #7 of 7 Old 09-30-2005, 12:30 PM Thread Starter
 
Join Date: Mar 2005
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Re:

Ok, Thank You.
Parkervess is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > General Mercedes-Benz


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome