loss of power in 1982 300SD TurboDiesel - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-27-2011, 04:30 PM Thread Starter
Junior Member
 
Join Date: Jun 2011
Vehicle: 1982 300sd turbodiesel
Location: lakeland, fl
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
loss of power in 1982 300SD TurboDiesel

recently my 1982 seems to have lost power upon starting from a stop. Ive changed the small rubber vacuum hoses that seem to any connection with the turbo and also replaced both fuel filters but no help. also took the air breather off so to able to view inside the front of the turbo and started the car which I was able to see the turbo spinning. BUT no power still!!
drrroybruce is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > General Mercedes-Benz


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New owner (1 day) of an '07 E320 and had an extreme loss of power mstepchinski Diesel Discussion 3 03-31-2011 07:54 PM
Spoadic loss of power E270 Cdi Avantgarde Ralphiespal Diesel Discussion 0 05-21-2007 01:40 PM
98 C230 stall/power loss jarrardp Mercedes-Benz Sedans/Wagons 11 05-09-2005 12:20 PM
260E loss of power while running cc DIY/Tech Help 2 08-29-2003 01:32 AM
260E loss of power while running cc Mercedes-Benz Sedans/Wagons 0 08-28-2003 10:35 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome