2013 C250 AC Compressor not being turned on by dash buttons - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-30-2019, 02:43 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
2013 C250 AC Compressor not being turned on by dash buttons

Hi - I have a 2013 C250 that I just replaced the compressor in and now the dash buttons will not turn the compressor on? Not sure what happened as everything was working in terms of turning on the AC, but it wasn't blowing cold air so I checked it out and needed to replace the compressor. The fuse's are good so I'm at a standstill with this issue. Any suggestions?
Dave Smith is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-31-2019, 09:38 AM
Administrator
 
Join Date: Dec 2016
Vehicle: 1999 ML430, 2000 ML320, 2005 E500 4matic wagon
Location: Wisconsin
Posts: 139
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
If the battery was not disconnected during the repair then the system sensed the loss of pressure and went into protection mode.

It needs to be reset or have the protection mode turned off. You will need a scan tool that can handle MB specific code and resets.
Noodles is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > General Mercedes-Benz


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome