1999 ML430 update.. sigh - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 11-13-2005, 12:51 PM Thread Starter
 
Join Date: Nov 2005
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
1999 ML430 update.. sigh

Well, things are going south fast.. <grin>..

My quest for nav CDs for the abovemention vehicle w/ pedestal-mounted Seimens OEM nav system is going quite poorly; nothing on Ebay for that model, and the dealer says they can't get'em either. Phadreus suggested i call Mercedes support, which I'll try tomorrow. Thanks.

HOWEVER.. I just took delivery of the car yesterday, and the CD changer doesn't work. It's the Bose system. (Don't get me started; I'm an audio professional and can't STAND Bose products, but hey, I liked the truck) I didn't thing to bring CDs to the test drive, so I noticed this flaw after the fact. The CDs load, but return a "disc error 1" most of the time for each and every disc as they attempt to load. OCCASIONALLY a disc will play, but usually for only a few seconds to a minute until it quits. I removed the changer, opened it, cleaned it, lubricated the gears, and cleaned the laser, but it didn't change anything.

Sooo.. any hints HERE? The nav cds won't do me any good until I fix the changer situation anyway.

Thanks... Looking forward to any help anyone can offer.

Barry
[email protected]
musechaser is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-14-2005, 03:35 PM
 
Join Date: Dec 2003
Posts: 1,467
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I would go right back to wherever you purchased the vehicle and have them get the changer working (or replaced).



PHAEDRUS242 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > M/G/GL/GLK Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome