ML 320 Won't Start - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 04-19-2007, 06:06 PM Thread Starter
 
Join Date: Nov 2006
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
ML 320 Won't Start

My 98 ML-320 wouldn't start the other day. I thought it was a battery or something mundane, but my mechanic told me it was the anti-theft system. I was told I needed new keys from Benz and a new transponder. Does this sound right to you experts?

I know the older MLs were not supposed to be that reliable, but this is the first major thing to ever go wrong with it. Thanks for your help.
Marcos is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 05-20-2007, 08:39 AM Thread Starter
 
Join Date: Nov 2006
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
***
Marcos is offline  
post #3 of 5 Old 11-30-2008, 04:51 PM
 
Join Date: Nov 2008
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ML 320 not starting

Did you get your truck running?
early40syoung is offline  
 
post #4 of 5 Old 11-13-2009, 10:42 AM
 
Join Date: Nov 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Its better u send your car to the local mecanic,they can help u out with this.

Last edited by aliyork35; 11-16-2009 at 02:11 PM.
aliyork35 is offline  
post #5 of 5 Old 11-14-2009, 08:59 AM
Gan
 
Join Date: Oct 2009
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Try With Your Spare Key ....
Gan is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > M/G/GL/GLK Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome