MY ML320 wont start then does - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 02-12-2008, 07:26 AM Thread Starter
 
Join Date: Feb 2008
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Question MY ML320 wont start then does

Hi can anyone help i have a 98 ML 320 that is tempremental , it wouldnt start for over 25 mins left it for 10 then it fired up .When i was driving it stalled on me in gear , any ideas .
acebandit is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 02-18-2008, 03:20 PM
Member
 
Join Date: May 2007
Location: aol.com
Posts: 65
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to gypsydog Send a message via Yahoo to gypsydog
Just a guess but crank sensors crap out no ryme nor reason

have worked on german cars 30 yrs
gypsydog is offline  
post #3 of 5 Old 01-06-2010, 11:18 PM
Junior Member
 
Join Date: Jun 2009
Vehicle: 1972 220D
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
A guess also, but my diesel was having similar problems. I replaced the fuel filters and replaced a ground and she has been running like a dream ever since.

One of my gas vehicles had similar symptoms and it was the fuel pump.

Good luck.
claytor is offline  
 
post #4 of 5 Old 05-21-2010, 04:11 PM
Junior Member
 
Join Date: Jun 2006
Location: california
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Just happened to me. Overheated crank sensor-$500 at my dealer.
LSgitt is offline  
post #5 of 5 Old 05-21-2010, 06:18 PM
Administrator
 
RedLiner's Avatar
 
Join Date: Jun 2009
Vehicle: 1993 SL500, 1998 SL500 pano top, 2005 ML270cdi.
Location: Spain and Gibraltar
Posts: 852
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Quote:
Originally Posted by LSgitt View Post
Just happened to me. Overheated crank sensor-$500 at my dealer.
Wow!!! That was a rip off
RedLiner is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > M/G/GL/GLK Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
88 300ce wont start! Ronin Mercedes-Benz Sedans/Wagons 1 06-08-2010 09:57 AM
E320 wont start Jay_Man Mercedes-Benz Sedans/Wagons 8 01-14-2007 07:35 PM
Car Wont Start any Help out there? Daheee Mercedes-Benz Sedans/Wagons 8 05-31-2006 12:24 AM
still wont start steevano Diesel Discussion 4 04-10-2005 11:29 PM
car wont start spitfire Mercedes-Benz Sedans/Wagons 1 06-27-2004 09:30 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome