2002 ml320 headlight issue - Mercedes-Benz Forum
 1Likes
  • 1 Post By cntroes
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 09-22-2014, 03:45 PM Thread Starter
Junior Member
 
Join Date: Jun 2013
Vehicle: 2001 ML 320
Location: Tucson
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
2002 ml320 headlight issue

On my ML I have a one headlight issue. The right side does not come on in low beam, only in high. I thought perhaps the HID bulb had burned out so I swapped the entire unit out for the left side and still nothing. Are there other components that come before the bulb and bulb starter I should be looking at to solve this issue? Any help in solving this issue would be well appreciated.

Charles
cntroes is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-09-2015, 06:36 PM
Junior Member
 
Join Date: Jun 2015
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Headlight issue

I've got the same problem. Does anyone have any ideas? Where does a DIYer find a good wiring diagram for a '99 ML320?
AndyCarson is offline  
post #3 of 5 Old 06-09-2015, 06:52 PM Thread Starter
Junior Member
 
Join Date: Jun 2013
Vehicle: 2001 ML 320
Location: Tucson
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
It's a simple fix

Quote:
Originally Posted by AndyCarson View Post
I've got the same problem. Does anyone have any ideas? Where does a DIYer find a good wiring diagram for a '99 ML320?
Ok, there are only three things stopping your light from coming on. The first being the bulb and I assume you checked that? The second is the igniter which is the black box attached to the back of the bulb and ballast which can not be reached without removing the headlight assembly. If you already swapped out the igniter and that didn't fix it, then it's the ballast located attached to the headlight assembly but on the bottom which you can't access till you remove the headlight assembly from the car. It's simple to see once you remove the light. Try and buy a used replacement on Ebay or locally as a new one is quite pricy. Any other help I can provide don't hesitate.

Charles
eric242340 likes this.
cntroes is offline  
 
post #4 of 5 Old 06-09-2015, 06:59 PM
Junior Member
 
Join Date: Jun 2015
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Huge thanks

Quick response! I'm impressed. Thanks again. I had checked the bulb - it's good. The existence of the igniter and ballast are new to me. I'll investigate and let you know.
AndyCarson is offline  
post #5 of 5 Old 06-09-2015, 07:10 PM Thread Starter
Junior Member
 
Join Date: Jun 2013
Vehicle: 2001 ML 320
Location: Tucson
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
If it has the lighting system instead of the halogen bulb, the info I gave you is correct.

Charles
cntroes is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > M/G/GL/GLK Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 ML320 - New Battery N4BBQ M/G/GL/GLK Class 5 10-12-2013 04:13 AM
2001 ML320 fuel sensor issue s.tutty1976 M/G/GL/GLK Class 0 08-06-2013 12:16 PM
Electrical issue C320 -2002 pgage DIY/Tech Help 3 05-10-2013 06:59 AM
Help Please ....key issue '98 ML320-V6 MT Goldminer DIY/Tech Help 7 09-18-2012 04:18 PM
2002 S55 BAS and ESP Issue NA80 DIY/Tech Help 1 06-16-2010 09:40 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome