Mercedes-Benz Forum

Mercedes-Benz Forum (https://www.benzforum.com/forum/)
-   M/G/GL/GLK Class (https://www.benzforum.com/forum/m-g-gl-glk-class/)
-   -   2013 ML350 Major Transmission Problem (https://www.benzforum.com/forum/m-g-gl-glk-class/34786-2013-ml350-major-transmission-problem.html)

bennynaas 09-20-2017 12:00 PM

2013 ML350 Major Transmission Problem
 
My 2013 ML350 with 54,000 miles is having transmission problems. After taking off from a stop sign, there was a somewhat loud "POP" and then the car wouldn't move. It wouldn't shift into drive or reverse. It was pushed into a parking lot and after putting it into park, I found that it still rolled. I had to put on the emergency brake so it wouldn't roll away. The car engine kept running the whole time. When trying to go into park or reverse there is a loud clicking sound. Not really grinding sounds, more of a harsh click. Trying to go the drive, there is no sound. It is at the dealer. They say they are backed up for 2 weeks. They said a new transmission might cost $10K to $15K. It might be a couple of months before I get my vehicle back. Any one had a similar problem? Any one had to replace a transmission? If so, how much was it including labor?
Thanks in advance for any help or advice.


All times are GMT -6. The time now is 06:41 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© AutoGuide

 
For the best viewing experience please update your browser to Google Chrome