Power Passenger Seat - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 06-14-2006, 08:16 AM Thread Starter
 
Join Date: Jun 2006
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Power Passenger Seat

None of the controls that operate the Passenger Seat on my 2001 c320 are functional. I checked the fuses (3 in all) and they look fine. A friend told me that it may be the motor; but I would imagine that there would be more than 1 motor that controls the various seat positions. Simply put; no matter what button/lever I try, nothing happens, not even motor sound. Is there some sort of "Passenger Seat Lock" that I'm not aware of? Any thoughts?

Thanks in advance!
Anthony
aviscomi is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-14-2006, 08:30 PM
Veteran Member
 
Join Date: Oct 2005
Posts: 678
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Tough to say. Most of the time, it is a blown fuse. But since it's not, could be alot of things. Maybe a loose connection to the seat control module, or perhaps the door control module or on the switch pack.
Zewerr is offline  
post #3 of 3 Old 08-19-2006, 11:57 AM
 
Join Date: Aug 2006
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Check the relay

I just had the same problem I discovered that it was the relay. I hope this helps.

-Dagmus X
Dagums X is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Mercedes-Benz Sedans/Wagons


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome