Alarm problem - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-18-2008, 11:50 AM Thread Starter
Junior Member
 
Join Date: Jun 2008
Location: NNJ
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Alarm problem

Hello all

I am encountering a strange problem with my 2003 C320. This just started today. I drove to my kid's school, stopped the car, got out and locked the doors with the remote. Then the car alarm went off. I noticed that the passenger side front door lock did not lock. So I unlocked the car (the alarm turned off), locked the passenger door manually, locked all other doors using the remote and the alarm went off again. I was in a bit of a hurry so I pressed the unlock button on the remote and went inside. I came out an hour later the alarm was going off again. I pressed the unlock button on the remote the alarm turned off. I drove to work and the same scenario happened. Any help or advice would be greatly appreciated before I contact the dealership. The dealers around here are not the most honest.
lancelot092466 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-19-2008, 06:43 AM Thread Starter
Junior Member
 
Join Date: Jun 2008
Location: NNJ
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Update

Here's what I did. I turned off the Automatic Security in the settings. That seemed to have fixed the alarm problem. The front passenger lock still needs to be locked manually. Last time I had this problem with my ML the dealer was going to charge me $1200 per door to fix the problem. Something about a leak in the vacuum system that lifts and pulls down the locking mechanism. I passed and said I'll use my fingers, they're free If anyone out there has any experience with this issue let me know if this is a DIY or should I just live with it.
lancelot092466 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Mercedes-Benz Sedans/Wagons


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Alarm disconnect on 99 e 430 fastmike99 DIY/Tech Help 0 09-02-2006 11:34 AM
CLK 320 ALARM. HOW TO luke162 DIY/Tech Help 0 11-19-2003 04:54 PM
Alarm System Roach 13 Mercedes-Benz Sedans/Wagons 2 08-04-2003 07:10 PM
After Market Alarm SonOfC320 General Mercedes-Benz 1 05-16-2003 08:57 PM
alarm chirp sdrejda Mercedes-Benz Sedans/Wagons 6 03-01-2003 01:49 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome