E320 Turn Signal problem/curiosity - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-17-2018, 01:01 PM Thread Starter
Member
 
Join Date: Nov 2014
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
(Thread Starter)
E320 Turn Signal problem/curiosity

The bumper side-mounted indicators stopped working on my E320.
The headlight and rear indicators still work.
The fuses specified to check is 3 & 41.
Those are fine.

I took off the covers and saw that the bumper mounted turn signal lights are on a different circuit from the headlight indicators.

This is probably due to that these bumper lights are also used for another purpose other than indicators.

Anyway, anyone had this problem and figured out why the bumper side mounted turn signal lights dont work while the headlight and rear lights do work ?

Thanks
daimlerbenzuser is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > Mercedes-Benz Sedans/Wagons


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signal Problem '76 300D benz76cal DIY/Tech Help 0 06-30-2005 07:09 PM
Turn Signal Stopped Working benz76cal Diesel Discussion 2 06-30-2005 06:23 PM
Turn signal & intermittant wiper problem sisis Mercedes-Benz Sedans/Wagons 1 02-28-2005 12:50 AM
Turn signal lens bradk Mercedes-Benz Sedans/Wagons 3 05-27-2004 11:16 AM
'99 SLK230 Where to Find Turn Signal Relay ? ? Jasonv44 DIY/Tech Help 0 09-18-2003 11:55 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome