Don - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-23-2019, 09:51 AM Thread Starter
Junior Member
 
Join Date: Aug 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Don

Just purchased a '99 E300TD with several problems to rectify...Will be doing lots of research and probably asking lots of questions..Thanks for the info..
degil is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-27-2019, 01:46 AM
Supporting Ven
 
carid's Avatar
 
Join Date: Jul 2009
Vehicle: Mercedes S-Class 2013
Location: Cranbury, NJ
Posts: 334
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Hi, Don and welcome to the group. You've come to the right place - this forum has some very knowledgeable folks that can help you out. Be sure to reach out if any help needed!

Mercedes Specialists
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Call Toll Free: 800.505.3274 |
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
carid is offline  
post #3 of 5 Old 08-27-2019, 06:26 AM Thread Starter
Junior Member
 
Join Date: Aug 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the add...Will try to contribute..
degil is offline  
 
post #4 of 5 Old 08-29-2019, 10:05 AM
Junior Member
 
Join Date: May 2018
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Welcome aboard!
BenzStyle is offline  
post #5 of 5 Old 08-29-2019, 10:35 AM Thread Starter
Junior Member
 
Join Date: Aug 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
After doing lots of searching and reading, I think you have given me the solutions to my problems and all have been resolved except the transmission non-shifting and I just received a new conductor plate to take care of that next week..

Thanks so much,,,Don
degil is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Forums > Off Topic/New Member Introductions


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome