Mercedes-Benz Forum

Mercedes-Benz Forum (https://www.benzforum.com/forum/)
-   S class (https://www.benzforum.com/forum/s-class/)
-   -   Hybrid S400 cannot start (https://www.benzforum.com/forum/s-class/23481-hybrid-s400-cannot-start.html)

tuysombo 04-10-2014 10:16 AM

Hybrid S400 cannot start
 
Dear all,

Please give some idea, I have S400 Hybrid after motobike hit the door and all the side airbag exploded. I have installed all new airbag and module but the airbag light illuminated.

My concern that the car cannot start the engine at all, I have parked this car over 3 months and I concern if the hybrid battery will be damaged also.

1- How can we start the engine again after the crash? Any reset button ?
2- Can we charge the hybrid battery if the car cannot start? Through battery charger or something?
3- Can it be SRS light preventing from vehicle starting?

I have checked with the local garage but seem he cannot make it work again. SRS light still on because the SRS module is not yet code.

Expect to get some input....

Best regards,
SOmbo

eric242340 04-11-2014 03:11 AM

I am sure the SRS is not causing this problem but to take a deeper look at the system I will need your vin number, then I can use WIS to find a way of doing this.

tuysombo 04-11-2014 04:57 AM

WDDNG9FB8BA400230.

I still have K88 fault in SRS as Pyrotechnical separator is too high. Not sure what it's.

1- is there a way to reset to get the engine start again after accident ?


Sent from AutoGuide.com Free App

tuysombo 04-11-2014 05:00 AM

1 Attachment(s)

eric242340 04-11-2014 05:18 AM

Quote:

Originally Posted by tuysombo (Post 69914)

I see from this pic you are using Star diagnostics, do you still have access to it? The fault code shown in the pic is in blue, if you press F3 on the computer panel with this code showing it will take you to the next stage of diagnostics and tell you what to check next.

eric242340 04-11-2014 05:38 AM

According to EPC you have two batteries, a high powered battery in the engine compartment for the Hybrid system and a starter battery in the trunk.

You will need to take all the pannelling out of the trunk to find it. Do not jump start the engine and it is better to disconnect the starter battery and charge it first then reconnect to the car.

tuysombo 04-11-2014 05:51 AM

I have connected my CTEK battery charger everyday to make sure the starting battery is fully charged and survive.

You mean you think the starting battery low? Or you want to do a hard reset?


Sent from AutoGuide.com Free App

eric242340 04-11-2014 05:58 AM

Quote:

Originally Posted by tuysombo (Post 69938)
I have connected my CTEK battery charger everyday to make sure the starting battery is fully charged and survive.

You mean you think the starting battery low? Or you want to do a hard reset?


Sent from AutoGuide.com Free App

I thought the battery may be low but this is obviously not the case so you should concentrate on the SRS problem. Do you have star diagnostics?

tuysombo 04-11-2014 06:01 AM

Yes. I do have star. But to get it program the SRS module is very poor.

I have team viewer if you could help.


Sent from AutoGuide.com Free App

eric242340 04-11-2014 06:10 AM

I have team viewer 8 but cannot use it as it is in Chinese. Is the SRS moduld new or used?


All times are GMT -6. The time now is 01:33 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© AutoGuide

 
For the best viewing experience please update your browser to Google Chrome