Mercedes-Benz Forum

Mercedes-Benz Forum (https://www.benzforum.com/forum/)
-   SL/SLK/SLR/SLS Class (https://www.benzforum.com/forum/sl-slk-slr-sls-class/)
-   -   Aux Battery Relay K57/2 Location - please! (https://www.benzforum.com/forum/sl-slk-slr-sls-class/32809-aux-battery-relay-k57-2-location-please.html)

Gregcr 11-04-2016 05:17 PM

Aux Battery Relay K57/2 Location - please!
 
Can someone please tell me the exact location of the K57/2 Aux Relay. What do I need to remove to get at it. Thanks!!!

Greg

eric242340 11-05-2016 03:28 AM

SL or SLK?

Gregcr 11-05-2016 07:49 AM

2008 SL55

It is not the k57 in the trunk.

Everything i read says its in the engine bay. Is is up against the firewall? Remove the windshild wiper panel. (Bolts hidden, or some sort of slid-up?)
Or could it be in the pass fender well? For this remove the tire and plastic fender well.

thanks

eric242340 11-05-2016 08:29 AM

I will look at starfinder at work in the morning and reply back.

Gregcr 11-05-2016 09:36 AM

Thanks, I may have the wrong part?
Some of the web post I see say two K57 relays, one in front and one in the rear.

In the end, the Aux Bat in the front is not charging just after starting like it should. I should see my meter go from ~12.5 to 14V just after start. Alt seems to be fine at 14.2V after start, and both bats are new (front and rear). The web pointed me to the AUX bat relay.

I have the Batt. message on the dash.

SL55 2008

eric242340 11-05-2016 09:41 AM

Quote:

Originally Posted by Gregcr (Post 91905)
Thanks, I may have the wrong part?
Some of the web post I see say two K57 relays, one in front and one in the rear.

In the end, the Aux Bat in the front is not charging just after starting like it should. I should see my meter go from ~12.5 to 14V just after start. Alt seems to be fine at 14.2V after start, and both bats are new (front and rear). The web pointed me to the AUX bat relay.

I have the Batt. message on the dash.

SL55 2008

Have you had the fault codes read out?

Gregcr 11-05-2016 10:03 AM

doing that today, before getting more under water.

eric242340 11-05-2016 10:20 AM

Quote:

Originally Posted by Gregcr (Post 91921)
doing that today, before getting more under water.

Let me know what the codes are.

eric242340 11-07-2016 11:34 PM

Have you had the codes read out yet? I searched both WIS and star finder and there does not appear to be a K57/2 on your car, only the K57 Battery lockout relay in the trunk.


All times are GMT -6. The time now is 01:09 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© AutoGuide

 
For the best viewing experience please update your browser to Google Chrome