Aux Battery Relay K57/2 Location - please! - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 11-04-2016, 05:17 PM Thread Starter
Junior Member
 
Join Date: Nov 2016
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Aux Battery Relay K57/2 Location - please!

Can someone please tell me the exact location of the K57/2 Aux Relay. What do I need to remove to get at it. Thanks!!!

Greg
Gregcr is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 11-05-2016, 03:28 AM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,870
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
SL or SLK?

ERIC
eric242340 is offline  
post #3 of 9 Old 11-05-2016, 07:49 AM Thread Starter
Junior Member
 
Join Date: Nov 2016
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
2008 SL55

It is not the k57 in the trunk.

Everything i read says its in the engine bay. Is is up against the firewall? Remove the windshild wiper panel. (Bolts hidden, or some sort of slid-up?)
Or could it be in the pass fender well? For this remove the tire and plastic fender well.

thanks
Gregcr is offline  
 
post #4 of 9 Old 11-05-2016, 08:29 AM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,870
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
I will look at starfinder at work in the morning and reply back.

ERIC
eric242340 is offline  
post #5 of 9 Old 11-05-2016, 09:36 AM Thread Starter
Junior Member
 
Join Date: Nov 2016
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Thanks, I may have the wrong part?
Some of the web post I see say two K57 relays, one in front and one in the rear.

In the end, the Aux Bat in the front is not charging just after starting like it should. I should see my meter go from ~12.5 to 14V just after start. Alt seems to be fine at 14.2V after start, and both bats are new (front and rear). The web pointed me to the AUX bat relay.

I have the Batt. message on the dash.

SL55 2008
Gregcr is offline  
post #6 of 9 Old 11-05-2016, 09:41 AM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,870
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Quote:
Originally Posted by Gregcr View Post
Thanks, I may have the wrong part?
Some of the web post I see say two K57 relays, one in front and one in the rear.

In the end, the Aux Bat in the front is not charging just after starting like it should. I should see my meter go from ~12.5 to 14V just after start. Alt seems to be fine at 14.2V after start, and both bats are new (front and rear). The web pointed me to the AUX bat relay.

I have the Batt. message on the dash.

SL55 2008
Have you had the fault codes read out?

ERIC
eric242340 is offline  
post #7 of 9 Old 11-05-2016, 10:03 AM Thread Starter
Junior Member
 
Join Date: Nov 2016
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
doing that today, before getting more under water.
Gregcr is offline  
post #8 of 9 Old 11-05-2016, 10:20 AM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,870
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Quote:
Originally Posted by Gregcr View Post
doing that today, before getting more under water.
Let me know what the codes are.

ERIC
eric242340 is offline  
post #9 of 9 Old 11-07-2016, 11:34 PM
R.I.P Always Remembered
 
eric242340's Avatar
 
Join Date: Jun 2009
Vehicle: Zotye 1.5T 2016 model
Location: Sichuan province China
Posts: 1,870
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Have you had the codes read out yet? I searched both WIS and star finder and there does not appear to be a K57/2 on your car, only the K57 Battery lockout relay in the trunk.

ERIC
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Enthusiasts Forums > SL/SLK/SLR/SLS Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Location of auxiliary battery for 2001 e320? ricalg DIY/Tech Help 1 01-02-2012 02:34 AM
Turn Signal Relay Location Robert Krieg DIY/Tech Help 1 09-15-2009 12:48 PM
Aux Fan Squeeky Mr Pink M/G/GL/GLK Class 3 11-04-2005 01:21 PM
no aux fan spin, fan relay? grish Diesel Discussion 1 08-12-2005 12:05 PM
Location of Turn Switch/Relay 89 190E 2.6 wrgiacona DIY/Tech Help 1 10-13-2002 07:37 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome