Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Hello, any help in answering these questions would be great. Thanks!

Why does the engine continue to run after I turn off the ignition. Is it the fuel cut off solenoid? If so, where is it?

The Tach is not functioning...I have replaced the Tach Amp to no avail....could it be the flywheel pickup?

Does anyone know where I can find an original MB jack, lugwrench and tool kit for this vehicle?

Where can I find touch up paint? I am not sure the color of the vehicle..it is a silver grey color.

Thanks for all of your help.

Clark
 

·
Registered
Joined
·
191 Posts
Hello Clark:

Welcome to the BenzForum. My best friend's name is Clark and he drives a 1986 300SDL.

You car has a 617.95 engine, which is very similar to the 617.951 in my 1983 300SD.
Why does the engine continue to run after I turn off the ignition. Is it the fuel cut off solenoid? If so, where is it?
The engine shut-off is vacuum actuated. Look for a missing, rotten, or simply disconnected vacuum line.
The Tach is not functioning...I have replaced the Tach Amp to no avail....could it be the flywheel pickup?
Yes, it could be, but this is a rare failure mode for the tach. I may be mistaken, but the pickup is probably on the front of the engine, mounted on the engine crank angle pointer bracket. There should be a procedure in the M-B service manuals for troubleshooting the tach pick-up.
Does anyone know where I can find an original MB jack, lugwrench and tool kit for this vehicle?
If our forum sponsor was not able to help you, try your local M-B dealer.
Where can I find touch up paint? I am not sure the color of the vehicle..it is a silver grey color.
Again, try the dealership. They have "paint pens" for small touch-ups.

Hope this helps.

Sincerely,
Scott
 
1 - 2 of 2 Posts
Top