Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1 (Edited)
Hello i have a 1996 c220, the temperature outside was 40C.

i was driving my car mainly on highways, at about...80-100km/h, and when i stopped near one shop to buy something, i noticed that temperature of engine got up to 100C!

then i turned it off, opened water lid, filled some water, checked and saw that one of the little fans was not working. (i have one main fan, and two little). but the main fan and another little one were working. then i touched it...and it worked. well, temperature got down to normal...around 90C. and it was OK.

my question is:

1.could i damage somehow my engine with 100C? or it is not much for 111 engine??

2. is there a possibility that i had more than 100C but didnt see it? (because i was stopping before this at another shop, for buying something, with idle engine, but after that i was again on highway..)

well, abou 2nd question i think that know...just was curious, cuz i think that with one working main fan, and one little fan its not possible to gather more than 100C... so... probably dont think so. +i was driving on highway...

but what u think about first question?

[some ppl said to me 100C is nothing]
and one more thing! during thi situation i had AC - ON, to full cool down. that's it.

but i want to know exactly,
thanks in advance
 

·
Registered
Joined
·
74 Posts
Discussion Starter #2 (Edited)
one more thing

oh and one more thing!

when this overheat happened, i took very cold water from fridge (had no other), and added it to that water tank...

could that crack my block?

but... we must take into account that, i added only 2 liters of whater, after this the water tank was almost full.... so... i had minimum 3 more liter of hot water, so the cold water mixed with hot water, and probably couldnt damage engine NO?

also say please, the water from that water tank goes to the engine through radiator? or directly?

of directly still it mixed and did trip over hot tubes, so cannot damage engine no?

and after that i drove around 50km... and there seemed no water under hood, and water level in tank almost same...thanx
 
1 - 2 of 2 Posts
Top