Benz Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Im having issues with top opening and closing. I get red dash message that trunk inside lid/latch not closed...it is def closed...I added hydraulic fluid to res in front and in trunk....still getting message. When I disconnect and then reconnect trunk battery it will open and close a couple times but then get same message......I then bought new trunk battery...same message and thing happening.....I then bought 2 new relays that are rt outside the pump thinking there is a short....same message..any ideas what to do????
 

·
Super Moderator
1997 SL500 Sport pano triple black 2010 R350 - sold 2014 E350 - sold
Joined
·
89 Posts
Have you looked at the latch mechanism? It may not be sending a closed signal when the lid/latch is closed.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Tks fir your response. I check the 2 wires under the latch and feel tight.
replaced battery in trunk. 2 relays outside of pump in trunk, checked face 71, 13, 41,etc….

I hate to change out the vacuumed pum as the top opens and closes fir a bit operating fine, then I get that red message on my dash and the trunk won’t close until I disconnect the trunk battery and then reconnect….any thoughts?
I appreciate any advise.
 

·
Super Moderator
1997 SL500 Sport pano triple black 2010 R350 - sold 2014 E350 - sold
Joined
·
89 Posts
I’m not certain on pump cost - you could call your local MB dealership parts department for that cost.
 
1 - 9 of 9 Posts
Top