Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi! Please forgive me not being a gear head and my general naivete when it comes to knowing how to fix a simple problem. Have patience please. I have a 2009 C300 Sport and I (stupidly?) added 19" AMG wheel to the car. I noticed almost immediatey that the car started feeling really rough and loud on the right front even when going over small items like the rail of a sliding gate. Hitting a small bump feels like a mule kick and its just awful.
Should I - buy a new control arm kit ($1200 MB) or ($450 Lemforfer) or buy new shocks or struts?
See Im clueless.
Please help...
 

·
Registered
Joined
·
52 Posts
I'm assuming you changed nothing else, just the tires/wheels? If so, and they're not physically hitting the fenders or something, then my first thought is way too much tire pressure.
Like if the tire shop had trouble popping the bead and forgot to lower the pressure. If used tires and it had a leak, some people will over fill so it lasts longer. Just guesses but check pressure and look to see if it's hitting anything in there. Other than that the only thing I can think of is if something is wedged in the suspension or the shock has seized, both of which I really doubt. Or sabotage from the installer that wants to "fix" your problem, which is rare imo but it happens.
 

·
Registered
Joined
·
7 Posts
my dear i will advice you on changing the 4 tires & 4 wheels as chivota instructed, this kind of issue has happue to me before with my car & i can highly
recommend & refer you to mr Jorge mrcaich, i am aware him is a very good dealers on tires & wheels and him will help you resolve any other issue on the car
Kindly contact him via -[email protected]
 
1 - 3 of 3 Posts
Top