Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello everyone,

Im back here after a long break, and since the summer is coming I need some help with this issue. I tried searching for it with the search button but came out empty handed, so i hope i'm not the only one with this kind of problem.

I have an 83' 300D, my pride and joy, when the AC works is cold as ice, but if i dont use it for a while, i just wont give cold air anymore, or it might during some periods but then it will just act as a fan.

what can i do?

thank you

George.
 

·
Registered
Joined
·
584 Posts
It sounds similar to a problem that I had with my '93. Basically the compressor was switching on and off. The source of the problem was a low pressure switch. This switch is a failsafe device that disconnects the compressor when the pressure is too high or too low so that it does not get burnt out. It could be that yours is working fine and something is setting it off like a clog in a line or no enough freon. You should have it checked out by a pro.

In my case, the system was fine, but the switch was (is) bad. I just bypassed the switch (located on the reciever/dryer) with a piece of wire and the A/C has been reliable since. I only did this because the system would have to be bled down and recharged to replace it. If I ever have to open it for any other reason, that switch will be replaced. Until then I need to be vigilant in having it serviced immediately if anything does go wrong.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Thanks for you reply, the problem that I have with the AC on this car is a recurrent one. I called the shop and they said it might be the diagphram, so i'm taking it to the shop to get it looked at.

hopefully this will be it.

George.
 
1 - 3 of 3 Posts
Top